Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Nautilus does not show my USB devices in its Devices pane. Nor does it mount them automatically. Looking at the syslog, I can see that kernel registers the event when I mount a device. Obviously, gconf has all the necessary settings for Nautilus set up.

I've searched Internet for some info, tried some solutions like disabling legacy floppy in BIOS -- does not work. Appreciate any help.

share|improve this question
    
I'm having a similar issue on 12.04. I plug in a flash drive or external USB drive, and it just won't automount. I can see from /var/log/syslog that the device is recognized, and if I run for example gvfs-mount -d /dev/sdb1 the device magically mounts to /media/{DEVICENAME}. To me, this seems like a problem with Nautilus or Gnome not being able to run gvfs-mount when the device is plugged in. –  JulioHM Nov 7 '12 at 1:31

2 Answers 2

Below are two links that might help if you haven't already tried these.

Hope these help. The second link solved my problem, but then my USB drives were showing up in Nautilus.

share|improve this answer

If you are using ppa:ricotz/testing you should also use ppa:gnome3-team/gnome3 (see https://launchpad.net/~ricotz/+archive/testing ). It could of course be a coincidence, but I had the same problem today and this solved it for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.