Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was doing some VirtualBox stuff today and I had so add my user to vbox group, well I did it wrong and I removed myself from sudoers. I used the recovery console and fixed it with this command:

usermod -a -G admin MyUser

Now I can sudo again, but I went to the graphical log viewer (because ubuntu is booting kinda slower now and I wanted to see if I can find something there), and I see that it can't access syslog and other files from there because it says I don't have permissions. Previously I was able to see all the log files from "System Log Viewer", without having to use sudo or anything, just launching it as my normal user.

What could be happening?

btw, I know I can access syslog from any text editor with sudo, but I want to find why I was able to access it from the GUI before without sudo and now I can't. I am using ubuntu 11.10

share|improve this question

1 Answer 1

Members of the adm group can read logfiles. Not only did you remove yourself from the admin group, you also removed all other groups.

To add yourself back to the adm group again:

sudo gpasswd -a MyUser admin
share|improve this answer
    
Thanks that worked, now the remaining errors are a lot of "no such file or dir" on log files like, jockey.log, user.log, boot, debug, btmp, messages, etc. Should I do something about that ? –  rlihn Jan 21 '12 at 14:23
    
/var/log/messages has been vanished a year ago iirc. You can ignore those warnings. –  Lekensteyn Jan 21 '12 at 14:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.