Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

My wireless driver is noisy. It prints out messages to the console every 10-30 seconds. So, if I'm working on VT1 or something, I get messages scrolling by all the time. Is there a way to shut this feature off? I like working on the virtual terminals, but this is making it hard to deal with. :)

Any ideas?

share|improve this question

2 Answers 2

up vote 12 down vote accepted

You can use the command

sudo dmesg -n 1

to suppress all messages from the kernel (and its drivers) except panic messages from appearing on the console.

To fix at each boot, add the command to:

share|improve this answer
Great, that is just what I was looking for. :) –  dpb Jan 25 '12 at 21:43
The dmesg -n 1 must be run as root, e.g. sudo dmesg -n 1. –  ntc2 Nov 11 '14 at 1:09

dmesg comes with two handy options for that:

-D, --console-off           disable printing messages to console
-E, --console-on            enable printing messages to console

dmesg -D is just a shortcut for dmesg -n 1, except that it stores the current log level, so that you can easily restore it with dmesg -E. So it's a bit more convenient than changing the log level with dmesg -n.

Additionally, you can check the current log level with:

$ cat /proc/sys/kernel/printk
7       4       1       7

man klogctl for more explanations on these numbers...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.