Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to hide certain user names from the the lightdm login screen (Ubuntu 11.10) I have found a work round by messing with uid's. In getting this solution I have found in my /etc/passwd file a user name ending in $ sign,what does this mean?

share|improve this question

If you are running Samba in domain controller mode (NT4), usernames ending with a "$" usually mean a (Windows) machine account joined to the domain.

Samba uses this to distinguish machine accounts from user accounts.

share|improve this answer

Can you past an example ? My guess with your user name would be a typo.

At any rate, to hide users in lightdm, edit /etc/lightdm/users.conf

# Graphical
gksu gedit /etc/lightdm/users.conf

# command line
sudo -e /etc/lightdm/users.conf

To hide only some users add to the "hidden-users" line

hidden-users=nobody nobody4 noaccess user1 user2

Users are separated by a space ;)

To hide all users use


As it turns out , there is a bug in lightdm such that it does not honor those settings in 11.10 or 12.04


While you are there, add yourself to the "affects me too"

You can , however, work around this by editing /etc/lightdm/lightdm.conf and adding the line (under [SeatDefaults] )

share|improve this answer
Hiding the user did not work for me on a updated 11.10, are you sure it works for current release? – Bruno Pereira Jan 21 '12 at 1:22
I'm testing it on 12.04 to check if I did something stupid. – Bruno Pereira Jan 21 '12 at 1:29
I updated my answer with a link to a bug report – bodhi.zazen Jan 21 '12 at 5:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.