Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Question:

On Ubuntu 11.10, I have no sound volume control as root.
I know this from earlier versions, as root you just had to manually start /usr/bin/pulseaudio, and then you got it.

This is still so. But as of 11.10, when I start /usr/bin/pulseaudio, I've got no more sound.

Note that I can view flash, movies, mp3s/oggs etc. without problems, but as soon as I start pulseaudio, all the sound is gone. When I pkill pulseaudio, sound is back.

Now, till now it has only been annoying, and I simply used alsamixer on the console to control volume.

Now, I want to watch a flash movie on youtube, but the sound volume is just too low to understand anything without holding my ears less close than 1 mm to the speaker...

Now I wanted to amplify the sound volume.
So I first looked into installing a alsa amplifier, and found this:
http://alien.slackbook.org/blog/adding-an-alsa-software-pre-amp-to-fix-low-sound-levels/

but /etc/asound.conf is not present on my system...

So I looked into something pulseaudio:
http://r8n.org/amplify-linux-sound-output-for-quiet-laptop-seakers-using-pulseaudio-ladsp-plugin/

I installed the swh plugin and the pavucontrol:

apt-get install swh-plugins
apt-get install pavucontrol

It seems to amplify well, as I see by the graphical output.
But I still hear nothing because of my problem with pulseaudio...

What can I do ?

I have a 64 bit system, in case that makes a difference.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I also have a 64 bit Ubuntu 11.10 system running on an XPS M1330 Notebook. Until this version of Ubuntu, I hadn't experienced any problems with sound too.

Now I have found that when I use a USB headphone and mic, I have to go into my Sound Settings menu (via a click on the volume icon in the upper right corner, or via the system settings menu) and manually change the hardware, input, and output settings to the USB setting. Then, when I remove the USB headphones, I frequently need to change all three settings back to the Internal Audio setting.

Once I make these settings, everything works fine and I have full volume control. However, sometimes when I use the volume controls within a webpage, it only increases the volume to the maximum level of what my system volume is set at. For instance, if my system volume is set to low, then maximizing the webpage volume only will get as high as low volume. So sometimes, I need to change the volume in both places. However, if I change the system volume directly, it usually increases/lowers the volume to the desired level.

The graphical interface for setting volume has been easy enough to work with that I don't use the terminal commands for sound. Perhaps someone else will post a command line solution.

Good luck. Doug

share|improve this answer
    
You're right. Just as I switched off totem after I started pavucontrol which I started it before I started pulseaudio, I realized I get a second device. It's well hidden in the configuration tab, in the gnome-volume-control plugin in the hardware tab. There I have to switch off Manhattan HDMI audio, in order for pulseaudio to use the internal audio by default, which is device 2... Now it works, and the audio amplifier works as well ! Thank you ! –  WitchCraft Jan 21 '12 at 14:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.