Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have looked far and wide and have not quite found the answer. I am running ubuntu 11.10, openssh, and vsftpd.

I am trying to configure my FTP to tunnel over ssh. My ssh connection works just fine and I can create the tunnel to my FTP port. When I go to use Filezilla to connect, it hangs at "Waiting for Welcome Message".

I think it is an iptables issue, but I can't seem to figure out what needs to be changed. When I take iptables down, it connects just fine. I don't want to open any more external ports, just my one SSH port, and I can't seem to get it right on the internal port forwarding rule. I always end up opening it to the outside.

I would love some help if anyone has any ideas and I hope I have made it clear. Thank you in advance!!

share|improve this question
2  
You realise ssh has ftp builtin called sftp? You just need a client capable of it like filezilla –  duffydack Jan 20 '12 at 20:51
    
Or even better, use nautilus -> connect to (ssh) server. –  bodhi.zazen Jan 20 '12 at 21:02
    
Thanks. I looked for sftp config files as i thought it was included, but I didn't see anything. Is there a way to configure it? Are they in the regular ssh etc folder somewhere? –  Siriss Jan 20 '12 at 21:44

1 Answer 1

In general a ftp client is using more than one port if it is using passive mode. If you open the config file /etc/vsftpd/vsftpd.conf and disable the passive mode with the parameter "pasv_enable=FALSE"

If your client needs the passive mode you can select the passive ports with the parameters pasv_max_port and pasv_min_port to a single port that you can forward through ssh too.

share|improve this answer
    
Thanks! I will try this! –  Siriss Jan 20 '12 at 21:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.