Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran an update on Ubuntu 11.10 to update to the 3.0.0-15-generic kernel today (Friday 20th January). I restarted the computer to find that I could not log in.

I'm using a Dell Studio 1555 laptop with Radeon 4500 graphics driver. I was using the proprietary graphics driver.

In recovery mode there is no option to boot into failsafe graphics mode (see picture below) Recovery Mode screen

After I pressed Resume Normal Boot the computer appeared to be starting normally but then I got taken to a black screen. shortly after it said Initcll: Event Failed

I logged in via tty1 and then tried to install fglrx but was given this error:

enter image description here

This is the contents of my xorg.conf file. I noticed that it says that it's using the fglrx driver even though it isn't installed:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "0-LVDS"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1366x768"
    Option      "TargetRefresh" "60"
    Option      "Position" "0 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Monitor"
    Identifier   "0-DFP1"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1366x768"
    Option      "TargetRefresh" "60"
    Option      "Position" "1366 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    Option      "Monitor-LVDS" "0-LVDS"
    Option      "Monitor-DFP1" "0-DFP1"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "Default Screen"
    DefaultDepth     24
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Virtual   2732 1920
        Depth     24
    EndSubSection
EndSection

Additionally, I ran locate fglrx and found that traces of the driver have been found in areas on my computer (see below). How can I remove these?

enter image description here

I have tried running aticonfig --uninstall but got the error One or more files have been altered since installation. Uninstall will not be completed. See /etc/ati/fglrx-uninstall.log for details.

Can anyone help me to either uninstall the graphics driver completely or install fglrx again.

Thanks

share|improve this question
    
Would you try booting an older kernel. Hold the shift key down when you boot. If that fails, you may need to use the "root" option and fix the problem on the command line. –  bodhi.zazen Jan 20 '12 at 19:18
    
the initctl problem is that the starting of lightdm didn't work. –  Mez Jan 20 '12 at 19:42

3 Answers 3

Try to

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak 

then

startx
share|improve this answer
    
That didn't work :-( how do I revert back to the old file? –  hellocatfood Jan 20 '12 at 20:03
    
switch round the bits after mv... sudo mv /etc/X11/xorg.conf.bak /etc/X11/xorg.conf –  Mez Jan 20 '12 at 20:39
up vote 1 down vote accepted

With the offline help of Mez I fixed this problem. It seems my problem stemed from where I installed the driver from. I downloaded the driver from the AMD website and installed it manually.

Trying to remove the software using apt-get remove removed fglrx-amdcccle but not fglrx itself. I got the checksum errors when trying to use aticonfig --uninstall because the reinstallation of fglrx-amdcccle didn't match the manual installation of fglrx.

In the end made sure that all other instances of fglrx had been uninstalled and then I ran sudo /usr/share/ati/amd-uninstall.sh --force. I was hesitant about doing this as it warns of system corruption but in my case it all went fine and then I was able to reinstall fglrx from jockey-gtk

share|improve this answer

Maybe i can help you to start your computer. as Mez mentioned backup and remove your /etc/X11/xorg.conf

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Looks like your dpkg crash during installation. fix it first

sudo apt-get -f install
sudo dpkg --configure -a

if apt-get -f install successfully install fglrx then your computer will start normally. If it fail then remove fglrx driver

sudo apt-get remove --purge xorg-driver-fglrx fglrx*

now edit /etc/default/grub

sudo vi /etc/default/grub [to write in file press insert in keyboard]

make following change in grub file

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="radeon.modeset=1"
GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="nomodeset"

Save and exit (Ese then : then x). Now update your grub

sudo update-grub

Now restart your computer.

default radeon (opensource) driver is perfect for Radeon card. fglrx is default performance is not good enough. it need to be tweak. Main problem with fglrx is it does not support suspense(BUG). Computer screen goes black when wake up from suspense. My recommendation is to use radeon driver. To install fglrx safely open jocky-gtk in ubuntu. Now select 2nd option and Active the driver. or you can download driver from amd site

EDITED:

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    Option      "AccelMethod" "EXA"
    Option      "MigrationHeuristic" "greedy"
    Option      "AccelDFS" "true"
    Option      "EnablePageFlip" "true"
    Option      "EnableDepthMoves" "true"
    Option      "ColorTiling"   "on"
    Option      "EXAPixmaps"    "on"
    Option      "RenderAccel"   "on"

EndSection

Append these options in /etc/X11/xorg.conf to speed up your GPU performance.

share|improve this answer
    
Thanks, will try this and then report back. In the meantime I've added more information about my problem –  hellocatfood Jan 20 '12 at 20:53
    
how do you install fglrx? did you use apt-get or download driver from amd site? what about this command to remove flgrx sudo apt-get remove --purge xorg-driver-fglrx fglrx* ? –  shantanu Jan 21 '12 at 17:31
    
I downloaded the driver from the site. I had ran those commands you specified before but it appears that there were still files left over from the manual installation of the driver. I removed these using /usr/share/ati/amd-uninstall.sh --force. After that I could log in and then reinstall. I've put this in an answer above. If you can add anything please do! –  hellocatfood Jan 21 '12 at 20:42
    
i have edited my previous post. See how to speed up your fglrx. –  shantanu Jan 21 '12 at 21:12
    
if your fglrx driver is ok then remove "radeon.modeset=1" from /etc/default/grub, also remove nomodeset from command string. –  shantanu Jan 21 '12 at 21:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.