Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was able to rotate one out of two monitors while using the latest nVidia driver (290.10 for Linux-x86_64), but the guide calls for using Xinerama which according to some is not compatible with Compiz. True enough, after restarting the rotation works (even in the login screen), but I can't start compiz anymore:

$ compiz --replace --display :0.0 --sm-disable &
compiz (core) - Fatal: No composite extension
Launching fallback window manager
Xlib:  extension "RANDR" missing on display ":0.0".

Is there any way to have all of the following:

  • Compiz effects
  • One rotated monitor
  • Drag windows between monitors
share|improve this question
    
For my AMD display card, I have the option in the "System Settings", "Displays" to choose Resolution and Rotation for each individual monitor using the default display driver with Compiz (no Xinerama). Do you not have this ability? Or do you lose it when using the proprietary driver? I personally don't install the proprietary drivers because for my use, there is no discernible difference. But I don't play games, except simple 2D ones like Freecell. I have always found the proprietary drivers to be a constant source of amusement, not the good kind. :) –  Marty Fried Mar 7 '12 at 1:06

5 Answers 5

Try xrandr. There is my rotate script for EeePC with external monitor

#!/bin/bash
# usage:
# ./rotate VGA1 right
s=${1:-'LVDS1'}
r=${2:-'left'}
echo $s;

# see `xrandr` for output modes for all screens
case $s in
'LVDS1')
  m='1024x600' #default resolution of EeePC 1005ha
;;
'VGA1')
  m='1024x768' #best resolution for LG FLATRON 795FT Plus which plugged to EeePC
;;
esac

case `xrandr | grep $s | sed 's/^\(.*\+0 \)\(.*\) (.*/\2/g'` in
'left')
  echo 'returning from left to the normal state on screen '$s' with the '$m' mode'
  xrandr --output $s --mode $m --rotate normal
;;
'right')
  echo 'returning from right to the normal state on screen '$s' with the '$m' mode'
  xrandr --output $s --mode $m --rotate normal
;;
*)
  echo 'rotating to the '$r' on screen '$s' with the '$m' mode'
  xrandr --output $s --mode $m --rotate $r
;;
esac
share|improve this answer
    
It just reports RandR extension missing here... –  l0b0 Mar 12 '12 at 16:58
    
"Package xrandr is not available ... the following packages replace it: x11-xserver-utils:i386 x11-xserver-utils" Then sudo apt-get install x11-xserver-utils -> "x11-xserver-utils is already the newest version." –  l0b0 Mar 13 '12 at 7:52
    
1. try disable Xinerama 2. try this: ubuntuforums.org/showpost.php?p=6738677&postcount=14 –  iegik Mar 14 '12 at 19:29

I'm not sure about this, but there is a gui tool that do those things you need,It's called grandr-gtk interface to xrandr and can be found in the synaptic package manager, simple one but i think it's useful (It does not work for me,Same nvidia drivers but single monitor)

share|improve this answer
    
Couldn't get it to work; it just reports "RandR extension missing". –  l0b0 Mar 12 '12 at 17:14

One can't rotate just one screen xrandr in a dual head head setup with an nvidia driver. Is my experience.

The reason seems to be that in ordinary nvidia "twinview" both screens are actually just one screen.

Installing a more modern NVIDIA driver (302.17) allowed me to rotate a single screen. Once installed it can be done from within the display app in Ubuntu 12.04

there is a link to the the fixing needed to be done after installing the nvidia beta driver.If you plan to use your computer in other resolutions than the screens native resolution.

share|improve this answer

Here's how I got my 3D+compiz dualscreen with one screen rotated working on nvidia on ubuntu lucid lynx 10.04:

1) Installed Ubuntu-x-swat PPA to get nvidia-current binary driver as new as possible (and to support xrandr 1.2) http://www.ubuntuupdates.org/ppa/ubuntu-x-swat

2) removed /etc/X11/xorg.conf to reset defaults

3) ran nvidia-xconfig after logout/login to generate a basic xorg.conf

4) Logout/login again, used nvidia GUI tool in system/administration to roughly place screens, saved settings to xorg.conf.

5) Identified screens from the terminal: xrandr

6) Ran the rotate command from the terminal: xrandr --output VGA-0 --mode 1280x1024 --rotate left

7) Modified xorg.conf to have proper fine placement based on nvidia GUI-tool: Option "metamodes" "DFP: nvidia-auto-select +0+230, CRT: nvidia-auto-select +1400+0"

8) Made the rotation permanent by adding these lines to /etc/X11/xinit/xinitrc

# Rotate right monitor CCW
xrandr --output VGA-0 --mode 1280x1024 --rotate left
share|improve this answer

I found this article which does not include turning Xinerama on (Xinerama = bad from my experience!)

http://tuxtweaks.com/2010/05/ubuntu-enable-rotation-nvidia/

it needs to be adjusted for 2 screens tho. Hope it helps.

share|improve this answer
    
Tried it; didn't work. I got one screen which I couldn't use for anything except move the mouse there. –  l0b0 Mar 12 '12 at 17:15
    
It only works for single head setup. Not for a dual head setup –  tomodachi Aug 1 '12 at 2:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.