Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sometimes I start typing a message to someone then stop, rethink it and change it or not send it at all. I don't want them to see "User is typing" messages. I see no option to disable this in Empathy.

share|improve this question
1  
In Pidgin, the option is under Tools -> Preferences -> Conversations -> "Notify buddies that you are typing to them" –  postfuturist Oct 26 '10 at 22:01
1  
I don't think there is a way to do this. –  TheX Oct 26 '10 at 23:52
    
Empathy settings are now in dconf, so I've installed dconf-tools and then launched dconf-editor. No trace of such an option. Ironic that some times ago people complained lack of this function. –  skalka Oct 27 '10 at 9:02
add comment

2 Answers 2

up vote 3 down vote accepted

There does not seem to be a way to achieve this. Empathy itself does not really have any privacy preferences that I've seen.

share|improve this answer
    
I suppose this is part of their keep it simple model. Maybe you can submit a feature request to them. I wonder if it even shows the other participant that you are typing. –  Noel Oct 27 '10 at 13:51
    
It definitely shows the other person that you are typing. –  postfuturist Oct 27 '10 at 16:45
add comment

Here is a patch to disable sending typing notifications for Empathy 2.34.0. For now, use the first attachment.

https://bugzilla.gnome.org/show_bug.cgi?id=668985

Patching 3.2.x.x is almost identical, but there are a few hunks of the patch that won't apply smoothly and need to be done by hand.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.