Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I find the Messaging Tray (the bottom bar) in GNOME Shell rather inconvenient. I'm looking for a way to disable it. KRSNA 2 ZED seems to have written an extension for doing just that, but I don't know how to install it. Any help would be appreciated.

I'm using Ubuntu 11.10 32-bit.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

I just managed to hide the messaging tray. Here are the steps I followed:

wget http://aur.archlinux.org/packages/gn/gnome-shell-extension-remove-bottom-bar/gnome-shell-extension-remove-bottom-bar.tar.gz
tar -zxf gnome-shell-extension-remove-bottom-bar.tar.gz
cd gnome-shell-extension-remove-bottom-bar/
mkdir -p .local/share/gnome-shell/extensions/remove_bottom_bar@k2z.com
cp extension.js .local/share/gnome-shell/extensions/remove_bottom_bar@k2z.com/
cp metadata.json .local/share/gnome-shell/extensions/remove_bottom_bar@k2z.com/

Now press Alt + F2 and enter r. After that, open gnome-tweak-tool Install gnome-tweak-tool and turn on the extension 'Remove bottom bar extension'.

enter image description here


There is an extension in the official GNOME extension website that lets you disable the messaging tray. You only have to download it from the site and turn it on in the gnome-tweak-tool to disable the corner.

share|improve this answer
    
Great answer, this did the trick. –  Exeleration-G Jan 21 '12 at 11:00

Download the tar file and untar the file. It holds 3 files...

extension.js, metadata.json, PKGBUILD.

According to Gnome Shell extensions you need to put these files in 1 of the following directories:

Extension installation locations

Extensions can be installed per-user in ~/.local/share/gnome-shell/extensions, or systemwide in /usr/share/gnome-shell/extensions and /usr/local/share/gnome-shell/extensions.

share|improve this answer
    
Thanks, but doing that didn't help. The extension doesn't pop up in gnome-tweak-tool either. –  Exeleration-G Jan 21 '12 at 8:51

check the metadata.json has the correct shell version as your gnome-shell and then logout should show up! if not then alt-f2 and type lg to see any errors.

gernerally when i install a new extension i change the shell version list to this

"shell-version": [ "3.2.1", "3.2", "3.3", "3.3.3", "3.3.4", "3.4" ],

makes it easier if there is an update :-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.