Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My PC CONFIGURATION :
UBUNTU 11.10 version 64 bit , ECLIPSE 3.7 , ANDROID SDK
I tried hard to remove adb error but itsms not working and showing following Errors:

/platform-tools/adb:Error While loading Shared libraries  

libncurses.so.5:wrong ELF class:ELFCLASS64

I even set all path for android set correctly but it wont works.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

The elf (executable and link format) problem is due to your setup using amd64 and i386 stuff. The official Android SDK only runs on i386 JVM, so you need to manually specify the i386 JVM on Eclipse.

  1. First install the Sun(Oracle) 32-bit JVM. Here is a step-by-step on how to do this:
  2. Add the JVM to Eclipse. Navigate:

    Window > Preferences > Java > Installed JREs > Add
    

    Put the location of the JVM. Probably will be /usr/lib/jvm/java7/ (my is /usr/lib/jvm/java-7-sun-1.7.0.01). The external libraries will be automatically added when you put the location of the JVM. Java7 Add Eclipse

  3. Set the Sun (Oracle) 32-bit JVM as default. Java7 Default Eclipse
share|improve this answer
add comment

As Marcos said, it's related to 32bit compatibility on your system.

Another solution, quite less elegant i must admit, is to install the 32 bit compatibility on your system :

sudo apt-get install ia32-libs
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.