Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Black screen on boot
My computer boots to a black screen, what options do I have to fix it?

While booting (but after choosing Ubuntu 11.10), the screen looses signal and I can not do anything. This is new on my machine. I always shut it down properly.
I have a x1300 video card.

What is the problem?

share|improve this question
add comment

marked as duplicate by David Planella, Jorge Castro, Tom Brossman, jokerdino, Mitch Sep 7 '12 at 8:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Ok, first thing you should try is to press "e" on the boot screen (with 11.10 selected) and find the line starting with something like "linux /boot/vmlinuz". Add radeon.modeset=0 at the end of that line. It should look something like that:

linux /boot/vmlinuz-(...) splash quiet radeon.modeset=0

Now press ctrl + x. If your system doesn't boot, then repeat that process, but add nomodeset instead, eg:

linux /boot/vmlinuz-(...) splash quiet nomodeset

If it boots properly with one of the above, then you should make this change permanent, so you don't have to do it every time. In order to do that, you should edit your grub configuration file:

sudo vi /etc/default/grub

In that file find a line starting with GRUB_CMDLINE_LINUX_DEFAULT= and add the option which made it work, eg:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Save the file, and tell grub to rebuild its config:

sudo update-grub
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.