Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to encrypt a folder, but the CryptKeeper icon doesn't show up in the tray. I'm not sure why. I've tried changing the whitlist to "all", but that didn't work. How do I get CryptKeeper to show up in the tray? Or, what would be an alternative to CryptKeeper?

share|improve this question

closed as off-topic by Seth, Braiam, guntbert, Eric Carvalho, Alvar Jan 4 '14 at 20:32

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, guntbert, Alvar
  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

The problem was fixed in recent (actually old) releases – Braiam Jan 4 '14 at 3:34
up vote 7 down vote accepted

It is a bug.

Here is the bug report:

Bug #760800 “Cryptkeeper icon do not appear on the gnome panel” : Bugs : “cryptkeeper” package : Ubuntu

And a work around:

How To Re-Enable The Notification Area (Systray) In Ubuntu, For All Applications ~ Web Upd8: Ubuntu / Linux blog

Basically you run the following command :

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

See the link for a more detailed explanation and an graphical solution.

share|improve this answer
I did that, still no luck. – Isaiah Bugarin Jan 21 '12 at 7:24
@IsaiahBugarin that has worked for me any time you edit these types of settings you will have to restart your machine or simply logout and login again – Martin Sep 18 '12 at 10:37

This was tricky, I use 12.04 and gnome-classic. I had to use "add to panel" and then select "Notification Area". I did also use the

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'cryptkeeper']"

In order for the icon to appear!

share|improve this answer

ok, Let us Solve this........ As a first step, let us check what are the white listed apps. for that open the terminal (cntrl+alt+T) then type:

gsettings get com.canonical.Unity.Panel systray-whitelist

This will display the whitelisted apps. suppose it be

['JavaEmbeddedFrame', 'Wine', 'scp-dbus-service', 'Update-notifier', 'desura'] that is crypt keeper is not listed......... So all you have to do is list the crypt keeper and update unity..... for listing the crypt keeper

type the following comand

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'scp-dbus-service', 'Update-notifier', 'desura', 'cryptkeeper']"

well it is listed and set...

Now reconfigure unity for that type

setsid unity

now some changes will happen in the screen and you will have your unity interface back in few seconds....... when you look at the systray you can find the Cryptkeeper icon.

(if crypt keeper was already present on your white list all you have to do is reconfiguring unity by typing above command) All the best.

(truecrypt is another encryption software)

I also request you to add the Tag Cryptkeeper and Crypt Keeper to your question


If you want to start the crypt keeper when you start your OS. add crypt keeper to startup applications.

share|improve this answer
Didn't work.... – Isaiah Bugarin Jan 21 '12 at 7:27
are you getting cryptkeeper icon in unity dash? – rjkrocks Jan 22 '12 at 8:27
Nope. I can dock the icon there, but when I click on it normally, it doesn't appear in the dash. – Isaiah Bugarin Jan 23 '12 at 1:20
Remove cryptkeeper... Then use autoremove function........ check then check the whitelists. if cryptkeeper is there remove it also.. then reinstall cryptkeeper. include cryptkeeper inthe whitelist as i mentioned above. THEN reconfigure unity using SETSID unity commnad (very important).. (If youare getting any error message please post it).. after some time (when it completes) open cryptkeeper from the unity.. your icon will appear in systray. from there you can operate. But when you restart it will dissappear. so you have to open cryptkeeper again from unity... Please let me know the result. – rjkrocks Jan 23 '12 at 2:46
I get a bunch of "[insert file name here] does not exist" where "insert file name here" is a file. – Isaiah Bugarin Jan 28 '12 at 4:20

Try this one - worked for me in 12.04! [look at the "work around" I added to bug this morning]

SuperEngineer (suprengr) wrote 7 hours ago:

Workaround: follow instructions at: [copied below] If you want to add support for Systray or Notification Area which has been disabled in Unity, install and launch dconf-editor from Ubuntu Software Center. Now to enable it just add an extra string 'all' under Desktop > Unity > Panel as shown in screenshot below (requires a logout to work). To revert, just click on 'Set to Default'.

share|improve this answer
$ gsettings get com.canonical.Unity.Panel systray-whitelist ['JavaEmbeddedFrame', 'Wine', 'Update-notifier']

$ gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'cryptkeeper']"
share|improve this answer
Please consider expanding your answer to include an explanation of some sort of what this command do. – Peachy Oct 12 '12 at 10:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.