Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use firefox for browsing, Ubuntu - 11.04 . Off lately it is behaving strangely. When i open a new instance of the browser, it opens random urls in new tabs which i have not visited before. Does any one know why this is happening ? Could it be a virus ? I thought Ubuntu was virus free. Are there any good antivirus software for Ubuntu ?

share|improve this question
    
Would you mind sharing what some of the URLs are? Is it possible that they are for add-ons that you didn't realize you had installed? –  michaelms Jan 20 '12 at 2:40
    
Also are you the only user on this computer? Is it one account per person or one account per machine? is your account password protected? –  Huckle Jan 20 '12 at 3:42
    
The url changes each time. Here is the latest one - 737577319 . It loads some text which looks like it is in some chinese language. I have not installed any addons recently. I also removed firefox from my comp, cleared all my profile data and installed it again. But this issue is still happening. –  Code maniac Jan 20 '12 at 3:43
    
Yes , i am the only user. There is only 1 account on this laptop and only i use it. It is password protected –  Code maniac Jan 20 '12 at 3:45
    
Does it happen when you restart in "safe mode" found by clicking on "help" in the menu? –  user25656 Jan 20 '12 at 16:12

2 Answers 2

Lets try to debug this. If you start firefox from the terminal, and use a new profile, does the problem persist ?

firefox -P

If so, then the problem is more likely with your DNS or internet provider. Try using OpenDNS

http://www.omgubuntu.co.uk/2010/09/how-to-switch-to-opendns-in-ubuntu-for-faster-browsing/

If the problem does not persist in a new profile, then your user profile is either corrupt of perhaps a malicious script.

In that case, personally, I would make a new profile and use NoScript

Take a look at securing firefox

http://ubuntuforums.org/showthread.php?t=671604

share|improve this answer

The IP address you posted belongs to a Japanese company called Accelia, which runs a Content Delivery Network. According to Google, none of the websites in their network are malicious.

Now, because you say it happens when you open a new instance of the browser, the first thing you should check is the start page. To do this, open Firefox and pick Edit -> Preferences from the main menu. In the settings window, check what is the current Home Page, and if it's something you are unaware of, then click "Restore to Default".

Let me know if it helps.

share|improve this answer
    
I have set the start page to blank. I have also enabled the option where firefox opens the tabs that were open, the last time firefox was running. On starting firefox again, it opens these tabs. Along with these, it opens a new tab as well which loads these urls. –  Code maniac Jan 20 '12 at 8:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.