Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I would like to know how do i prevent my Ati card from turning on when i enter on ubuntu 11.10. My bios only lets-me shutdown intel hd card or leave the both on but i want to know if is possbible to completely shutdown without having to access to the bios.( if is possible to turn of without using Vgaswitcheroo even better!)

My system is: Acer 3820tg-- intel core i3 350M, 2.26 Ghz L3, Ati Mobility Radeon HD 5470 up to 2138 MB hyper memory, 13,3" HD LED LCD, 4gb DDR3, SSD corsair 60GB sata 2.

EDIT: I now know what is missing on the answers! What only i had to do was: I edited /etc/rc.local file and added the next lines:

  1. sleep 6

  2. echo ON > /sys/kernel/debug/vgaswitcheroo/switch

  3. echo IGD > /sys/kernel/debug/vgaswitcheroo/switch
  4. echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

And then save the file and restart. It wasn't need to do anything more. It should be possible to use only the intel card now. By the way, i didn't blacklisted the radeon driver because doing it make my ati card wake up. (use it at your own risk. i only tested in my system)

Second edit: For those using this to use the intel card, pay attention because adding the sleep 6 to /etc/rc.local might disable your sound card making ubuntu only show a dummy card in sound settings (i noticed this problem in ubuntu versions after to 12.04.2 hardware stack enabled version). To fix this you need to remove the sleep 6.

share|improve this question

marked as duplicate by BuZZ-dEE, Danatela, Eric Carvalho, nux, Richard May 30 at 21:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

3 Answers 3

You can blacklist its kernel module. You can do that by editing blacklist.conf

sudo vi /etc/modprobe.d/blacklist.conf

You should probably add something like this:

blacklist fglrx
blacklist radeon
alias radeon off
alias lbm-radeon off

That will blacklist ATIs proprietary driver (fglrx) as well as its opensource counterpart.

Edit:

Ok, how about using vgaswitcheroo then? Add those lines to your /etc/rc.local file before exit 0:

modprobe radeon
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

That should work.

share|improve this answer
    
Nothing. It didn't worked. And if i do " $ lspci | grep VGA " it shows: 00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12) 02:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5400 Series] –  Celso Jan 21 '12 at 1:47
    
Please see an update to my answer. –  Voitek Zylinski Jan 21 '12 at 7:01
    
But should i keep the blacklisted modules and add that commands to the rc.local? –  Celso Jan 21 '12 at 17:17
    
When i blacklist the radeon and fglrx modules, does the system uses another module? because that answer doesnt really turn off the ati card. –  Celso May 30 '12 at 10:38
add comment

I have a HP Pavilion dm4t-1100 (also with ATI 5470) and there is advanced hidden mode in the BIOS with more options. Press A and hold it while entering BIOS (for example if you enter BIOS with F10, press F10 and A at the same time) and you should see more menus.

The advanced mode gives following options for the card: dGPU, iGPU, hybrid.

  • Hybrid option powers on both cards, so after booting Linux will be able to access both and vgaswitcheroo is active and before starting X you can switch to which one you want.

  • For me, dGPU-only option does not work - the laptop freezes with a black screen and caps lock led flashing and I have to do a power off, after which everything is back to the default setting - Hybrid.

  • iGPU-only works and turns off ATI, so after boot lspci no longer shows ATI card - only Intel works and vgaswitcheroo is not started at all (/sys/kernel/debug/vgaswitcheroo directory does not exist at all).

share|improve this answer
    
well, my laptop bios really have stuff hidden but, cant access it without the risk of damage the Bios, accordingly to this post on ubuntu forums: ubuntuforums.org/showthread.php?t=1787312 . i think i will wait a few more months until the devs explore more this subject. But thanks for the effort! ;) –  Celso May 31 '12 at 15:44
add comment

In order to actually turn off the card you need to have both intel and radeon loaded so that the vgaswitcheroo infrastructure gets initialised, and then you can run

echo OFF | sudo tee /sys/kernel/debug/vgaswitcheroo/switch

which will turn off any GPUs that vgaswitcheroo thinks are unused; in this case, it'll be your Radeon. You'll need to do this each boot; it's not persistent across restarts.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.