Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Screen session over putty connections from windows are colorless and have a character set problem (shows in curses applications like aptitude). A screen session on a proper terminal works just fine.

How do I configure putty to make this work properly?

It's an ubuntu server.

share|improve this question
    
what's the output of the following command in your terminal session? echo $TERM –  ImaginaryRobots Jan 19 '12 at 21:00
    
Not really an answer, colors work here, and with screen. This link, however, has a number of tips - dag.wieers.com/blog/content/improving-putty-settings-on-windows –  bodhi.zazen Jan 19 '12 at 21:15
add comment

1 Answer

up vote 5 down vote accepted

Not sure about the colors, but for the characters, you need to set putty to use UTF-8 as the code page.

share|improve this answer
    
Thanks, that did it for both the characters and the colors. –  John Jan 20 '12 at 13:07
    
@John, an upvote and/or accepting as the correct answer is the proper way to say thanks ;) –  psusi Jan 20 '12 at 14:32
    
I did accept it some time ago (apparently after you wrote this), but it appears I lack the required reputation to vote you up, sorry. –  John Jan 21 '12 at 15:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.