Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have big problem. I am using MS VC++ on win and Qt Creator on ubuntu. So, today I have problem. I can't change my permissions on my flash drive (FAT32).

Q: How I can change permissions on FAT32 flash-drive?

UPD: I can't do it under root.

share|improve this question

2 Answers 2

up vote 6 down vote accepted

vfat does not support linux permissions. You can set permissions manually when you mount the device.

Unmount the flash drive from nautilus, but do not remove it.

sudo mkdir /media/flash
sudo mount /dev/sdb1 /media/flash -o dmask=000,fmask=111

You can possibly work around the issue if you use ntfs on the flash drive, and in that case mount it with the permissions option.

sudo mkdir /media/flash
sudo mount /dev/sdb1 /media/flash -o permissions    

With the permissions option chown and chmod should work.

See man mount

Other options might be to use ext2 on the flash drive (smaller overhead) and the fs-driver on windows

http://www.fs-driver.org/

share|improve this answer
    
Thanks. It is medicine for me. –  tucnak Jan 19 '12 at 19:46
    
If you have a mount option that works you can add an entry in fstab. help.ubuntu.com/community/Fstab –  bodhi.zazen Jan 19 '12 at 19:47

FAT32 does not support Linux-like permissions.

The only possibility which comes to my mind is, to change the settings in /etc/fstab for the whole drive. On mounting, these permissions are mapped to the whole drive, but you can't distinguish between executable files, read and write permissions from file to file.

And since you need to execute a directory to enter it, you need global execute permissions. And therefore global read permissions too.

A typical entry would look like this:

/dev/pny    /media/pny  vfat    defaults,users,exec,uid=1000,gid=46 0   0

uid would be your uid, gid=46 is plugdev on my system, used for the hotplug daemon.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.