Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of all, sorry to ask this, I'm sure that this was asked so many times before. Second, sorry for the English, it's not my native language. And Third, thank you in advance.

So, I hope the follow info will help, here's a log. http://www.alsa-project.org/db/?f=07089caf530494bc4bc23e1d1cd56b3a5fae03c6 I already check 'System -> Preferences -> Sound'. Here's a screenshot http://i.imgur.com/Ghwnj.png

> jorge@jorge-desktop:~$ sudo lshw -class multimedia     
> *-multimedia  
>        description: Multimedia audio controller
>        product: VT8233/A/8235/8237 AC97 Audio Controller
>        vendor: VIA Technologies, Inc.
>        physical id: 11.5
>        bus info: pci@0000:00:11.5
>        version: 60
>        width: 32 bits
>        clock: 33MHz
>        capabilities: pm cap_list
>        configuration: driver=VIA 82xx Audio latency=0
>        resources: irq:22 ioport:e400(size=256)

Tried with no results:

>     sudo apt-get remove --purge alsa-base
>     sudo apt-get remove --purge pulseaudio
>     sudo apt-get clean && sudo apt-get autoremove
>     sudo apt-get install alsa-base
>     sudo apt-get install pulseaudio
>     sudo apt-get install ubuntu-desktop

Also

>     sudo gedit /etc/default/grub
> 
> from:
> 
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
> 
> to:
> 
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"
> 
>     sudo update-grub
> 
> And Reboot... without any result.

EDIT: I made sure that everything it's fine with aplay -l and lspci -v and lsmod; and checked alsamixer, it's not in mute.

Well I'm running out of ideas.

Thanks.

share|improve this question

2 Answers 2

Before purging and reinstalling (which can make things worse) it is recommended to go through the steps outlined in

Ubuntu Wiki Debugging Sound Problems

  • Is our sound hardware working at all? - Test with another OS if possible
  • Is it a configuration issue? - Sound should be fine on booting a live system
  • Are speakers muted?
  • Is it an ALSA or a pulseaudio issue?

To find out you can see most relevant information on running

ubuntu-bug audio

Sometimes the putput from this gives you hints on where to look first. If there is something you don't understand - ask here.

Also, it is always worth a try to remove broken user settings by

mv ~/.pulse ~/.pulse.OLD

Another easy to perform action that may sometimes help is to temporarily remove all attached external audio devices and restart the system.

share|improve this answer
    
It fixed itself with an update, now works with music players, and the system sounds, etc; but still have trouble with the browsers, thanks for the help anyway. I'll open a new thread because flash it's diferent issue than this. Regards. –  Jorge Jan 20 '12 at 17:57
    
Glad you got it running. Flash is a different thing indeed :P –  Takkat Jan 20 '12 at 18:33

i have an hp probook 4720s with ubuntu 11.10 x64 with latest kernel update and no sound coming out from the laptop.

Linux PC543host 3.0.0-15-generic #25-Ubuntu SMP Mon Jan 2 17:44:42 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

i did not noticed when the sound got broken since i work often with low sound volume , but now all my audio devices were unmuted and audio volume was at 100% and still no sound. neither on internal speakers nor audio jack output.

i ran the ubuntu-bug audio command and it said i had master volume to 0 , i ran the displayed command : "alsamixer -D hw:Intel" and i set volume to 100 % but still no sound. then i decided to select another audio device but the other devices shown where spdif output which i have nothing connected to.

i reselected back the device HDA Intel (IDT 92HD81B1X5) and pluged in the audio jack. and there were sounds comming from it (banshee was running ) unplugged the jack and the sound came back to the internal speaker.

Thank you

Massimo

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.