Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I love GNOME Screensaver application and all the themes that can use be used with it -the defaults and additionals from the repositories. So I would like to prefer the "Random" theme selection.

The problem: there's a choice as Images Directory among themes. When I opt for Random, screensaver shows the content of my Images directory as well. No need to give details, but this is not suitable for more than one reason. Shortly, that directory is very private for me and screensaver, by nature, is to be wieved by everybody when we lock the screen and leave the computer.

Once upon a time there were a number of discussions on the issue, but the developers' approach was something like this: "This is not a bug, this is a feature". Technically it may not be considered as a bug, but still it is a personal security issue for me.

A workaround may be not to use the default Images directory for images -or putting just a few screensaver-safe image in it- and to use another directory for the personal images, instead. I don't like this way because desktop integration of GNOME & Ubuntu makes that directory -which comes as default- functional for some image related task.

So the question: How can I choose Random option for the GNOME Screensaver and yet not include the Image directory to the line?

share|improve this question
1  
BTW, you should always store those more than one reason images in a semi-hidden directory (like ~/nrop/ or ~/.nrop/) so anyone you casually let use your computer won't stumble across them. –  Roger Pate Oct 27 '10 at 15:28
1  
I think I have a .hidden stored away somewhere... –  8128 Oct 27 '10 at 19:05
    
@Roger Pate & @fluteflute I'll take your advice(s) into consideration, seriously. –  marenostrum Nov 1 '10 at 14:07

2 Answers 2

The Random screensaver simple shuffles through all the other available screensavers.
So the way to fix this is to disable the Pictures folder screensaver.

From the GnomeScreensaver FAQ:

How can I remove some themes from the list of themes shown in the preferences?

Eventually this feature will be added to the preferences dialog itself. But for now the not so elegant solution is to run the following from a command-line:

PATH="${PATH}:`pkg-config --variable privlibexecdir gnome-screensaver`:/usr/libexec/xscreensaver" \
gmenu-simple-editor gnome-screensavers.menu

Simply uncheck the Pictures folder screensaver.

Edit Menus screenshot

share|improve this answer

There are "Wishlist" bug reports about this on Launchpad and the GNOME Bugzilla. I wouldn't get your hopes up that this will be implemented in the graphical interface anytime soon though.

But it turns out your problem is solvable with a little effort! (This looks like a lot of steps but actually it's not hard.)

  1. Choose the Random option in System->Preferences->Screensaver
  2. Open the gconf editor (Alt+F2 and enter gconf-editor)
  3. Navigate to apps/gnome-screensaver
  4. Right click on the themes 'key' and click "Edit Key..."
  5. Click on screensavers-personal-slideshow and press Remove

Editing the gconf key

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.