Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my computer I have a neat little Lubuntu installation running. It loads a nice LXDE desktop themed with the nice Lubuntu theme whenever I use lxdm to login. When I use the startlxde command to start LXDE however, the desktop session that gets loaded is a default, bare bones LXDE session which appeals less to my taste. Kind of a shame!

The reason that I use startlxde to start a session is that I'm attempting to log on remotely using NX. I need to supply a command to NX that starts up an X desktop it can use, and startlxde does just that. But as stated above doesn't load the right theming and lxpanel configurations unfortunately.

Is there a way to load the same Lubuntu configuration (with the proper theming and lxpanel settings) as lxdm does when I log on over NX?

share|improve this question
up vote 8 down vote accepted

I connect to Lubuntu using NoMachine's client under Windows 7. Under your NX client connection under the Desktop area, select "Custom", then click on settings. Just be sure the settings look like this:

NXClient Settings for Lubuntu

Now connect and you're ready to go.

share|improve this answer
Thanks, this is exactly what I was looking for. Kind of feel stupid for overlooking it! – DCKing Mar 26 '12 at 20:39
+1 tyvm - exactly what I needed! – kfmfe04 Nov 10 '12 at 14:00
I did not have the startlubuntu command. I had to use lxsession -s LXDE instead. Also, it is important to have the New virtual desktop box checked. – ctbrown Dec 6 '14 at 15:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.