Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

i'm experiencing a strange problem with dual monitors. when i set the dual monitor via "nvidia settings" and save the setting to xorg.conf, the default unity theme and icons are turning back to gtk default. i also get an error telling me "could not apply the stored configuration for monitors"

here is my xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 280.13  (buildd@yellow)  Fri Aug  5 12:31:28 UTC 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Chi Mei Optoelectronics corp."
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 540M"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0, CRT: 1680x1050 +1920+0"
    SubSection     "Display"
        Depth       24

here is an example of what i'm talking about:

how can i fix this? thanks in advance.

share|improve this question

closed as off topic by belacqua, fossfreedom May 25 '12 at 14:19

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Welcome to Ask Ubuntu! This question should instead be filed as a bug report, thanks! Instructions here. I will flag this question for closing. –  htorque Jan 19 '12 at 12:17

1 Answer 1

Maybe the resolutions set for monitors was too high? Try setting very small resolution and check if it saves options then.

share|improve this answer
misery, unfortunately setting a smaller resolution is not helping either. –  Mengu Jan 19 '12 at 14:17
Did You try using open driver? –  Misery Jan 24 '12 at 14:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.