Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got a problem with installing ubuntu with the help of wubi. My configuration is a laptop with single hdd, Windows XP SP3 and my user account with admin rights. Wubi version is rev245.

I can manually change the file boot.ini (and I already removed the read-only flag) but wubi always crashes with the following error:

Traceback (most recent call last):
File "\lib\wubi\application.py", line 58, in run
File "\lib\wubi\application.py", line 132, in select_task
File "\lib\wubi\application.py", line 158, in run_installer
File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
File "\lib\wubi\backends\win32\backend.py", line 606, in modify_bootini
File "\lib\wubi\backends\common\utils.py", line 239, in write_file
IOError: [Errno 13] Permission denied: 'C:\\boot.ini'

I added the following line manually

c:\wubildr.mbr="Ubuntu"

but I am stuck with a grub shell bootloader that doesn't recognize any kernels (as these files weren't copied).

Is there a switch to tell wubi to proceed even if it can't access boot.ini perhaps?

Thank you for your help!

share|improve this question

3 Answers 3

Try to login to the account with administrator permissions instead of just selecting Run as .. Administrator.

share|improve this answer

Make sure wubi.exe is run as Administrator. I think you can right-click, select Run as.. Administrator.

share|improve this answer
1  
I already tried this, doesn't change anything. –  powerbar Jan 19 '12 at 8:46
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  atenz Aug 23 '12 at 16:05
1  
I don't really understand how this is not an answer. It was not a request for feedback. It was an answer based on the assumption that if he's not allowed to open a system file, it's because he's not running the program as an administrator -- which is required. –  Jo-Erlend Schinstad Sep 3 '12 at 5:43

Right click>run as>USERNAME>Untick the box underneath worked for me

share|improve this answer
    
I might want to detail this answer a bit more. For starters, "right click" on what? –  Luís de Sousa Nov 26 '13 at 13:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.