Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've deployed a number of laptops to our staff with encrypted LVM. I've used the alternative CD, whole disk & guided partitioning. This is the second laptop that came back to me with the same symptoms, namely the issued password doesn't work any more.

Both laptops are Probook 4530s (i5, 4 GB, 600GB). It's no keyboard mapping issue, there is only one keyboard installed and the pass is ASCII + numbers, no special chars. There is zero chance both users messed around with the disk utility and tried to change it.

I've researched the issue after the first laptop came back to me, had no luck finding anything similar and wrote it off as bad luck. But two laptops in 14 days, I'm freaking out here, encrypted FS was the primary reason we chose Ubuntu for deployment.

I suppose there is no way I can access the FS. cryptsetup luksDump /dev/sda5 lists a single key slot.

So is this a known bug? Are there guidelines as to what to watch out for in regards to deployment on a laptop, like don't hibernate or whatever?

* UPDATE *

After wiping the disk, installing a fresh Ubuntu 11.10, doing the update & upgrade and verified everything is working, I've shipped the laptop back. Less than 24 hours later, it's the same issue. The password doesn't work any more.

I mean, if it's a faulty disk or bad RAM or whatever it is inconceivable that it manifests itself by screwing up just the password. Is it maybe an issue with the disk size, should I make the partition smaller or eliminate swap?

share|improve this question

closed as off topic by fossfreedom Apr 2 '12 at 22:42

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I have used LUKS on my laptop for years and I have never seen this problem. You should be able to access the crypt with a live CD. help.ubuntu.com/community/… –  bodhi.zazen Jan 19 '12 at 17:24
    
I've booted off a live CD and tried accessing it and it's still a no-go. –  sostacked Jan 20 '12 at 17:22
    
I am so sorry you are having this problem, hope you have backups and that someone has a better solution =) –  bodhi.zazen Jan 20 '12 at 17:48
    
Well I am not too concerned with the data that's lost, I'd like to know what's causing the problem. This is now the third time it has happened, they are asking me now if we made a bad call with Ubuntu and if maybe Truecrypt + Windows is the way to go. Please help. –  sostacked Jan 20 '12 at 18:11
    
As I said, I've never seen this behavior with LUKS (been using it for years). You are probably best off filing a bug report. –  bodhi.zazen Jan 20 '12 at 18:40
show 1 more comment