Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a X-ONE W-601 desktop pc:

3,1GHz AMD QuadCore Athlon II 645 X4      
8 GB DDR3 RAM   
1000 GB Harddisk 7200RPM  
ATI Radeon HD5750 with 1GB DDR5 RAM  

I'm running Ubuntu 11.10 64-bit and have installed the proprietary driver, but still games lag and videos a little bit. Been googling around and seen that it has something to do with the older drivers from AMD and KMS, but no guide helped me correctly through to make my graphic card work smoothly. I don't know if this helps but "fglrxinfo" in terminal shows:

display: :0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5700 Series
OpenGL version string: 4.1.11005 Compatibility Profile Context

And the driver check command shows:

[ 51.184] (II) ATI Proprietary Linux Driver Version Identifier:8.88.7

Any help appreciated :D

share|improve this question
    
Did you install the proprietary driver from the AMD support site or from the Ubuntu Software Center? The AMD site is more current and may solve your problem. –  esoltys Jan 19 '12 at 0:34
    
I installed it from the Additional Driver tab. Well also tried as you suggest to get the latest from AMD's site but now guide helped me through to make it work. Following step by step and the end test fglrxinfo shows: Mobile Device instead of something with Ati.. –  Morten Fjord Christensen Jan 20 '12 at 14:09
    
OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. Regards, –  Ringtail Mar 27 '12 at 20:15

2 Answers 2

flash lags--sure: unless you used http://www.omgubuntu.co.uk/2012/01/youtube-lens-adds-minitube-playback-option/ or https://addons.mozilla.org/en-US/firefox/addon/flashvideoreplacer/ or any apps to stream youtube videos such as Minitube, VLC...

video lags--sure: if you're using Totem to play high definition videos. Try VLC or Mplayer

I don't think your lags related to the graphics driver.

share|improve this answer
    
Good to know Ill try to see if I can install those programs and make it works. Thx. –  Morten Fjord Christensen Jan 20 '12 at 13:44
    
No difference at all after installing the mozilla addon and VLC. Still lagging a bit in movies (sometimes hard to see but are there) and an annoying amount in games. –  Morten Fjord Christensen Jan 20 '12 at 14:23
    
Actaully there is a difference.. Now youtube videos wont play at all –  Morten Fjord Christensen Jan 20 '12 at 14:27
    
you may want to read this ubunturoot.com/2010/05/… –  vanlong441 Jan 20 '12 at 16:13

I'm using exactly the same graphic processor with exactly the same drivers. Do not install the drivers from any different place than Ubuntu, or you will perhaps be seeing yourself dealing with more problems. Simply do the following for extreme quality:

From the AMD Catalyst Control Center:

  1. Disable the "free of fragmentation desktop" technology, from the "screen options" section. Desktop and video will clearly go faster.
  2. Set the "wait for vertical sync" option, from the "3D" section, to "Activated, except when told by the application". Then 3D animations will be perceived smoother.
  3. Disable the "Catalyst A.I." technology, since applications can be tuned more accurately without it since no 3D configuration in games is auto-managed by the driver.

  4. If your screen supports HDMI conection and audio output, use HDMI over any other connection; since you will be able to use the integrated HDMI sound processor on the graphic card, which is of superb quality, and the YCbCr 4:4:4 pixel format, which is more accurate than any other. No problem for now if you see black borders because of doing so.

  5. In other case, try using DVI connection if supported; since it's the remaining output that is digital.
  6. Set your screen to its standard values and disable any auto-improving technology; since in this way the image will be the closest to what the multimedia creators saw in their screens when creating the contents, and they're the best people to set this values.

  7. If your computer is connected to the monitor using a DVI or an HDMI cable, Set the graphics processor to scale the screen in the "screen manager" section; since scalers of this time are usually better than the screen's ones.

  8. If your computer is connected to the monitor using a DVI or an HDMI cable, set the "graphic processor scaling" method to "keep aspect ratio". This will make screen aspect ratio to be always corrected represented and images will not be "fat".
  9. If you see black borders in the screen, set the "scaling options" bar to "0%". Repeat this if you see black borders appearing again in a different resolution that you intend to use in a game.

In CompizConfig, a tool you can download from the software center:

  1. Disable the vertical sync option in the "OpenGL" section. This will make Unity to run smoothly.
  2. If you're using a desktop with a big screen, in the "Ubuntu Unity Plugin" section set the "Hide Launcher" option to "never". You will note a great improvement in the usability of Unity.

If you notice problems with the Unity shell or with Adobe Flash, in the log-in screen choose to do so using "Ubuntu 2D" shell instead of "Ubuntu" one.

I will wait for the day we could not spend the 75% of time solving problems caused by proprietary software.

share|improve this answer
    
Thx a lot for your answer. I'll try it out! –  Morten Fjord Christensen Jan 20 '12 at 13:43
    
Unfortunately it didn't make a difference. –  Morten Fjord Christensen Jan 20 '12 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.