Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to use a program to fix my booting. It asked me to type a long line of code into the terminal to install grub-PC

It says in terminal that it may have been moved to another repository.

How do I get it to install?

Edit:

The program ('it') is called boot repair. It asks me to put this into the terminal:

sudo chroot "/mnt/boot-sav/sda3" apt-get install --force-yes -y grub-pc

The terminal gives this error:

Reading package lists... Done Building dependency tree Reading state information... Done Package grub-pc is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package grub-pc has no installation candidate

share|improve this question
    
What is "it" and what exactly is the command that "it" told you to run? If you tried to install grub-PC, it is lower case, not upper case pc. –  psusi Jan 18 '12 at 18:15
    
@psusi It's a program called boot-repair. I did type the pc part lower case. –  Liam W Jan 18 '12 at 18:35
    
the chroot changes the effective root filesystem so by changing the root to /mnt/boot-sav/sda3 you may have 'removed' most of apt's configuration files from the new filesystem. –  Huckle Jan 18 '12 at 19:52
    
The above command looks ominous, you should not need to force anything. What package are you trying to install, grub-pc or boot-repair ? Did you properly configure your chroot ? –  bodhi.zazen Jan 18 '12 at 19:59

1 Answer 1

up vote 0 down vote accepted

Well, I fixed it.

I needed to copy the /etc/apt/sources.list to /mnt/boot-sav/std3/etc/apt

It then worked.

PD: You may need to sudo chroot "/mnt/boot-sav/sda3" apt-get update, sometimes the program is not on the list

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.