Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought an Nokia Bluetooth Phone Bh 503. It works just fine with my Android phone, but with Ubuntu it even get recognized. I already paired the Ubuntu with my Android, but with the bluetooth phone it even find it.

What can be the problem?

Already search in Google for answers, but almost always the problem is with bluetooth that doesn't work, but in my case it works, but not with the headset.

Already install almost all packages about bluetooth, like blueman, bluez, gnome-bluetooth, bluetooth, etc.

share|improve this question
1  
I think you are referring to a Nokia Bluetooth headset bh-503, i have same problem with my Ubuntu precise. i'm still looking for solutions but any help is very much appreciated. thanks. –  dsaint Jan 18 '12 at 16:21
    
Looks like is a commum problem: ubuntuforums.org/showthread.php?t=1463610 But some people using it: projectzeorymer.wordpress.com/2011/09/01/… –  euDennis Jan 19 '12 at 14:52
1  
i just connected my bh-503 few days ago with precise, you have to turn-off and turn-on again your headset, when turning on hold the button until the lights turn into blue and green, scan the device. that works for me. but the audio is very awful. it works great with lucid. –  dsaint Jan 23 '12 at 10:25
    
Hmm, I will try again them. I thought it could be an problem when bluetooth from my laptop, Dell 15R. Maybe it doesn't support something. Maybe I will try with and external bluetooth adapter too. About the audio, when I was searching for solutions, I saw many people with same problem and fix it with some packages that I don't remember very well now. –  euDennis Jan 24 '12 at 11:08
    
Work! Thanks Eric! The audio isn't perfect too, I will try to fix it. I had to turn on the "configure new device" on PC. Then, I just turn On the HeadeSet, wait sometime, Turn it Off and when turn it on again, keep pressing the button, work perfectly. –  euDennis Jan 24 '12 at 11:13
show 5 more comments

3 Answers

(comment to answer solved issue)

  • I just connected my bh-503 few days ago with precise, you have to turn-off and turn-on again your headset, when turning on hold the button until the lights turn into blue and green, scan the device. that works for me. but the audio is very awful. it works great with lucid. – erickjohncuevas Jan 23 at 10:25

  • It's just working, I Don't have sure if it's because the packages or not. – euDennis Mar 9 at 0:14

share|improve this answer
add comment

I have the same headsets and works for me in a fresh install of Ubuntu 12.04, I'll tell you what I did:

  1. Install Blueman and open it.
  2. Open Blueman, put the headset in pairing mode (when turning on, press the power button until you see a blue light blinking)
  3. Hit "Search" In Blueman. You'll see the headset there.
  4. Right click on the headset, "add", then "trust", then "Pair". Immediately after that, "Connect to" - and choose the option "Audio Sink".
  5. If the headset is connected, will beep twice and the light will change to green. Enjoy.

If you don't have sound after that, follow this steps:

1) Stop, and if possible, close everything that is playing audio.

2) Go to Blueman, right click in the headset, and check that the headset is not connected to headset service and audio sink at the same time. If is the case, disconnect it from headset service only.

3) Try again, if doesn't' work, disconnect it from audio sink as well, and reconnect, or remove it and repeat the procedure again. Is a bit of a headache in the beginning, but the headset works fine. Also, make sure to set up the headset before starting to play music, otherwise you most likely will have issues.

Hope this helps.

share|improve this answer
add comment

i just connected my bh-503 few days ago with precise, you have to turn-off and turn-on again your headset, when turning on hold the button until the lights turn into blue and green, scan the device. that works for me. but the audio is very awful. it works great with lucid. – erickjohncuevas Jan 23 at 10:25

share|improve this answer
    
After the headset is connected, you have to change an option in sound config, something about use the A2P, I don't remember now... but you have to do that only in the first time you connect. –  euDennis May 15 '12 at 18:12
    
@euDennis thank you, i already did. –  dsaint May 17 '12 at 9:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.