Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.10 and have installed GIMP last night. But today, my update manager is showing that your system has broken packages and dependencies. When I try to install the GIMP update that is available in the update manager, following error occurs.

The package system is broken

 The following packages have unmet dependencies:

 gimp: Depends: python-gtk2 (>= 2.8.0) but 2.24.0-2 is installed
       Depends: libc6 (>= 2.11) but 2.13-20ubuntu5 is installed
       Depends: libfontconfig1 (>= 2.8.0) but 2.8.0-3ubuntu2 is installed
       Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.24.0-1ubuntu1 is installed
       Depends: libglib2.0-0 (>= 2.24.0) but 2.30.0-0ubuntu4 is installed
       Depends: libgtk2.0-0 (>= 2.20.0) but 2.24.6-0ubuntu5 is installed
       Depends: libjpeg62 (>= 6b1) but 6b1-1ubuntu2 is installed
       Depends: librsvg2-2 (>= 2.14.4) but 2.34.1-2 is installed
       Depends: zlib1g (>= 1:1.1.4) but 1:1.2.3.4.dfsg-3ubuntu3 is installed
       Depends: python (>= 2.7.1-0ubuntu2) but 2.7.2-7ubuntu2 is installed

Then I tried to run various commands from Terminal and following errors pop up.

randomhero@randomhero-Inspiron-N5010:~$ sudo apt-get install -f
[sudo] password for randomhero: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  gimp
Suggested packages:
  gimp-help-en gimp-help libgimp-perl gimp-gap gimp-console
The following packages will be upgraded:
  gimp
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/4,388 kB of archives.
After this operation, 324 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 213862 files and directories currently installed.)
Preparing to replace gimp 2.6.11-2ubuntu4 (using .../gimp_2.7.4-2011102201~oo_amd64.deb) ...
Unpacking replacement gimp ...
dpkg: error processing /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for menu ...
Errors were encountered while processing:
 /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

The Update Manager shows GIMP update under Other Updates(LP-PPA-matthaeus123-mrw-gimp-svn ) Is that official repository? Do I need to remove that repository? If yes, how?

Also the Ubuntu Software Center pops up error saying "Items cannot be installed or removed until package catalog is repaired."

When I click repair, it again gives me following error.

installArchives() failed: perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
p    erl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_IN.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 213862 files and directories currently installed.)
Preparing to replace gimp 2.6.11-2ubuntu4 (using .../gimp_2.7.4-2011102201~oo_amd64.deb) ...
Unpacking replacement gimp ...
dpkg: error processing /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for menu ...
Errors were encountered while processing:
 /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb
Error in function: 
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)

I tried to remove gimp package with sudo apt-get remove gimp, but it shows following error.

randomhero@randomhero-Inspiron-N5010:~$ sudo apt-get remove gimp
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gimp-gmic : Depends: gimp (>= 2.6) but it is not going to be installed
 gimp-paint-studio : Depends: gimp but it is not going to be installed
 gimp-plugin-registry : Depends: gimp (>= 2.6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I don't know how to go ahead and fix this error. I need to install few applications, but I can't because of these errors. I don't want the GIMP software as such, I just installed just in case. But I want my Ubuntu Software Center to work.

Please help me, thanks in advance.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

You'll have to eliminate gimp-paint-studio , gimp-gmic , and gimp-plugin-registryto fix your last issue.

sudo apt-get remove gimp-paint-studio gimp-gmic gimp-plugin-registry

For repository , use apt-add-repository -r ppa:user/repository to remove one

share|improve this answer
    
Thanks a lot. I fixed the issue with Synaptic. It took care of everything when I removed GIMP. I had tried to remove those paint studio and registry things, but they were giving me same error. :\ –  Electrifyings Jan 21 '12 at 12:35
    
This also helped me, thank you! –  LEOPiC May 10 '12 at 5:51

If you did want to install gimp from that PPA, its webpage (https://launchpad.net/~matthaeus123/+archive/mrw-gimp-svn) has the solution:

GIMP 2.7.5 Will not work with the current glib and gtk in Oneiric. To fix the problem install these repos

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main

deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main

share|improve this answer

I'll tell you what worked for me.

Remove form repository manager these 3 PPAs:

http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu
http://ppa.launchpad.net/ricotz/testing/ubuntu
http://ppa.launchpad.net/matthaeus123/mrw-gimp-svn/ubuntu

Because it has a wrong dependency list for Oneiric (libglib2.0).

And remove gimpdata from Synaptics remaining from provious install attempts.

Then add this PPA from command line:

sudo add-apt-repository ppa:jmou/ppa
sudo apt-get update
sudo apt-get install gimp

This will install GIMP 2.7.4.

I don't know how to fix de wrong PPA package for Oneiric.

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.