Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ive seen plenty of guides on how to prevent the launcher/sidebar from ever auto-hiding, but how would I prevent it from ever showing except when I press the left cmd/win key?

share|improve this question

2 Answers 2

For Unity

You can try CCSM Install ccsm to autohide the launcher.

To do that, install CCSM by clicking the link. After installing it, open CCSM and go to 'Ubuntu Unity Plugin' under Desktop.

Choose 'Autohide' option in the dropdown list next to 'Hide Launcher'. Now, the launcher will show if you move your cursor to the left side or you press the Meta key.

So, in order to prevent the launcher from appearing when you move your cursor to the left side, go to 'Reveal mode' in the same option page and unselect all the selected corners. If your dialog box looks like the picture below, your launcher won't appear even if you move your mouse to the left side.

enter image description here


For Unity-2d

You can try using dconf-tools Install dconf-tools.

Enter these commands in a terminal:

dconf write /com/canonical/unity-2d/launcher/hide-mode 1
dconf write /com/canonical/unity-2d/launcher/use-strut false

Alternatively, you can use the GUI of dconf-tools.

Go to com -> canonical -> unity-2d -> launcher and change hide-mode to 1 and untick the option in use-strut.

Note: For Unity-2d, editing the reveal mode for launcher is currently not available and hence, you can't prevent it from showing when you move your cursor to the left side.

enter image description here

share|improve this answer
    
How does that solve the question of the user? I think he knows how to hide/auto-hide the launcher, that is not the issue, he wants it hidden always, except when he presses the super key, no mouse. –  Bruno Pereira Jan 18 '12 at 8:41
    
Thanks. Edited the answer. –  jokerdino Jan 18 '12 at 9:37
    
Damn. Im stuck with 2d at the moment as Ubuntu is in a VM on my development machines. May be able to get 3d working, just havent looked in to it as I have not had a need. I may just switch to gnome 3 if its too big of an issue, at least I know how to disable it there –  jdc0589 Jan 18 '12 at 19:22

If you install Ubuntu Tweak you can customize some Unity settings, It is possible to set it to "auto hide" where it is always hidden until you mouse to the left even if there is no window there. That is all I can think of but if your problem is it popping up when not wanted you could always try changing the timeout where you would have to leave your mouse against the left edge of the screen for a desired amount of time until the launcher will reveal it's self, this can also be changed in Ubuntu tweak. For the Ubuntu tweak .deb file you can download it at the link below. http://ubuntu-tweak.com/ Hope this helps, Ross

share|improve this answer
    
Dont think a timeout will work for me. I run ubuntu in a VM on my development machine, and unity pops up (immediately) every time the vm looses focus, so I dont think the timeout will apply. –  jdc0589 Jan 18 '12 at 19:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.