Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I always use a proxy to connect to the internet in Windows as well as in previous versions of Ubuntu, but in Ubuntu 11.10 it seems that the proxy settings I set in the GUI are not being applied system-wide.

I can access the internet in Firefox with its own proxy settings. I can access internet in the terminal (i.e. I am able to use apt-get for some small programs). But in Ubuntu software centre or update manager it is not working.

share|improve this question
    
I have the same problem - if I set manual proxy settings in Firefox, I can access the internet, but if I set it to use the system proxy settings (even though they're the same!), connections just time out. –  Martin McNulty Mar 9 '12 at 12:53
    
I have the same issues but after reading <a href="askubuntu.com/questions/89437/… </a> it worked. The link is : askubuntu.com/questions/89437/… Hope it works for you too. –  user123190 Jan 14 '13 at 13:58
add comment

4 Answers 4

You should export proxy by root user

Just type in a terminal:

sudo -s
export http_proxy=http://yourdomain.com:port
apt-get update
share|improve this answer
1  
su doesn't work (and has never worked) by default in Ubuntu, for becoming root. You need to use sudo instead. sudo -s is the proper equivalent of su. –  Eliah Kagan Jul 7 '12 at 13:09
add comment

This tutorial worked for me:

First. You must install dconf-tools in the following ways:

sudo apt-get install dconf-tools

or Using Software Center Install via the software center

Second. Run dconf-tool the way:

dconf-editor

Third. In the Configuration Editor menu select System>> proxy

Goto “system >> proxy” change “mode” to manual and select “use-same-proxy“.
Goto “system >> proxy >> http” give your proxy information there and select “enable” option.
Goto “system >> proxy >> https” give your proxy information there, do the same things on ftp part.
Make sure socks have “0” (zero) on “port” and nothing on “Host” field.

http://loewyi.com/info/proxy-problem-google-chrome-ubuntu-11-10/

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Stefano Palazzo Jan 21 '12 at 16:44
add comment

I was having this problem when I first installed Ubuntu 11.10. I don't know which of the following steps solved it, but this is what I did:

  • Open a terminal
  • Run export HTTP_PROXY=http://<myproxy>:<port> to set up the proxy server for that terminal session
  • Run sudo apt-get update
  • At this point, the update manager popped up and asked if I'd like to install c. 300 updates, which I did
  • Restart
  • Install dconf with sudo apt-get install dconf-tools

    or Using Software Center Install via the software center

  • Run dconf-editor, select system > proxy > http and click enable (as per the tutorial in teleblog's answer)

And now it all seems to work :)

share|improve this answer
add comment

Go to system setting>network. There you can manually adjust your proxy settings.

share|improve this answer
    
of course i did it. but it does not work for complete system even after clicking "Apply System Wide" button For Eg : i am unable to use internet in update manager and softwrae centre –  Prakash Jan 18 '12 at 17:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.