Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use an external monitor, my file selection dialog boxes seem to be huge -- wider than my larger screen. I assume it is a nautilus issue since it happens whether I'm trying to open a file to upload (in firefox) or attach (in thunderbird) or just open it in LibreOffice. See screenshot:

Screenshot

The browser window fills my left-hand monitor, the "open" dialog is wider than one screen, and wider than the window that spawned it. It's huge. It didn't used to be huge.

Is there some way to force dialog windows to be smaller by default? Whenever I try to open/attach/upload a file I have to re-size the finder dialog before I can see what I'm looking at. I don't understand why it is defaulting to such a huge window.

share|improve this question

5 Answers 5

up vote 7 down vote accepted

I managed to find a solution by figuring out that the dialog modal is always 1440 px wide. So I did grep -r "1440" ~/.config (I also looked in ~/.gnome, ~/.gconf, ~/.gconfd/ but they didn't turn up anything interesting.) I stumbled upon this gem:

.config/gtk-2.0/gtkfilechooser.ini:GeometryWidth=1440

Removing that line (and the corresponding GeometryHeight) solved the problem for me.

share|improve this answer
1  
Thanks a bunch for this. It solved my problem, too. +5 :) –  Scott Severance Mar 14 '12 at 6:55
    
This has been bothering me for the age of the known universe, thank you. –  Insperatus Feb 22 '13 at 8:10

The window size in stored in a dconf key. You should install dconf-editor (it's in the software centre). Then, navigate to org.gtk.settings.file-chooser and adjust the window-size key.

Does this solve your problem?

share|improve this answer
    
No, it doesn't. –  Amanda Feb 8 '12 at 21:09

I solved this by modifying a plugin in compiz-config manager: Windows Manager:Windows Rules:Size Rules:

New-> Size Windows: "type=Dialog", and set the size.

share|improve this answer

I'm not sure, but it looks like the Archlinux guys had a similar issue where the gconf-key /apps/nautilus/preferences/navigation_window_saved_geometry was missing.

Does this solve the problem?

share|improve this answer
    
This is unrelated. The problem in this question is file selection dialogs, not Nautilus. Furthermore, the referenced GConf key already exists on my machine and is set to the size at which Nautilus windows open (598x318 in my case). And, the referenced page describes a bug existing in 2009, which has presumably been fixed by now. –  Scott Severance Feb 3 '12 at 18:42
    
No dice. The key is there and changing it doesn't seem to impact the file selector dialog size. –  Amanda Feb 4 '12 at 2:18
    
ok. sorry it didn't help. One option less then... –  BHM Feb 4 '12 at 13:26

Open the file below (no need to terminal; it’s under your own home):

 ~/.config/gtk-2.0/gtkfilechooser.ini

I solved my problem on my netbook by this numbers:

GeometryX=100
GeometryY=100
GeometryWidth=600
GeometryHeight=400

I’m not sure what these values really mean; but they are good and position the file chooser at middle center of your screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.