Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a clean Lubuntu 11.10 install. In the days that I've used Microsoft Windows, I've used an external microphone for calling with Skype. The microphone was plug-and-play, and no drivers were needed.

Right now, I'm using Skype on Lubuntu. I've installed PulseAudio, because it comes by default in Ubuntu, and it seemed wise to do so therefore. Whenever I make a test call, I won't get any input: it seems like the microphone doesn't record anything.

So, my question is: how can I get an external (line-in) microphone to work in Lubuntu?

share|improve this question
up vote 5 down vote accepted

I got it working by doing this. You should enter the commands in a terminal.

  1. Install pulseaudio if you haven't done that already:

    sudo apt-get install pulseaudio

    or using Software center Install via the software center

  2. Install pavucontrol and pavumeter if you haven't done that already:

    sudo apt-get install pavucontrol pavumeter
  3. Restart to get pulseaudio running

  4. Start pavucontrol, and make sure that input/output is set to Audio Stereo Duplex
  5. Start alsamixer, and set the values as follows:


- Master: 100
- Set the others values on 63, including CAPTURE


- Line-in: 40
- Mic: 63
- Phone: 40
- Aux: 40
- Analog Source: mic
- Digital Source: i2s in
- Shared Mic: mic in

If you get a strange 'looping beep' right now, don't worry, this happened to me too.

Start Skype.

Because of the restart you did earlier, Skype should automatically use PulseAudio. Make sure that you don't allow Skype to change the volume settings. You can do that in Skype's volume settings.

Make a test call to confirm that the microphone works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.