Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having trouble with Ubuntu recognizing/finding/mounting one of my hard drives. I dual boot Ubuntu and Windows 7. I had Ubuntu 10.04 and all drives showed up under "Places" I could click on any of my Windows/NTFS drives and they would mount as they should. I have since updated to Ubuntu 10.10. One of my drives no longer shows up in "Places" or in Nautilus. I can open gparted and it is listed there, but if I try to click the mount button, I get an error.

I am currently at work and can not post any screenshots or errors, but will happily do so later. I was just hoping that someone might be able to give me something to try when I get home.

250gig SATA hard drive (Windows7/NTFS) - recognized/mountable 200gig PATA hard drive (Ubuntu 10.10) - recognized (obviously) 1TB SATA hard drive (NTFS) - not recognized/won't mount

Thanks!

share|improve this question
    

6 Answers 6

Your ntfs-3g binary may be out of order due to newer incompatibility.

When an upgrade is made, the binaries that have been installed through compilation (and not installed through the package manager) are not upgraded.

If you took the .tar.gz or .tar.bz2 source for ntfs-3g and compiled and make installed before the upgrade then you need to compile and make install again.

If you need to format the partition, FAT32 is safer but does not allow files larger than 4 GB.

share|improve this answer
    
There exists no ntfs-3g kernel module, as it uses fuse. –  JanC Oct 26 '10 at 22:44

I had similar problem when I bought 2Tb Western Digital external drive. It was formatted in a way that only Windows could recognize it. I just deleted partition from that drive and created it again - that fixed the problem.

Read more here: http://ubuntuforums.org/showthread.php?t=1569941

share|improve this answer
    
I'm not sure that is the best option here. As I said, I was able to access the drive fine in 10.04. After my upgrade to 10.10, the drive is no longer available to mount. –  Dave Oct 27 '10 at 18:46

Try to use PYSDM tool (search on software centre or by typing terminal sudo apt-get install pysdm). It works with my 1TB external HD.

share|improve this answer

You can try installing the package ntfs-config to see if it is detected and if it is, than you can use that tool to configure it.

share|improve this answer

I recently switched from win xp to ubuntu 10.10 (firt time I ever used this os, and I like what I see/ experience! However I can no longer access my WD 1 TB networkdisk, guessing this is because of the ntfs file format. (WD also states that win and OS X are the only suported OS) I`m hopeing there is an easy way around this challange? All help would be much obliged!

share|improve this answer

Found the answer here http://ubuntuforums.org/showthread.php?t=1698296 on posts 8,9, and 10

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.