Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My fonts are horribly unkerned in LibreOffice. Example:

Here's a comparison, LibreOffice on top and Inkscape below.

Comparison of Kerning between LibreOffice and Inkscape

As you can see, LibreOffice messes up the kerning. The font is Ubuntu, 10pt in LibreOffice and Ubuntu, 13px in Inkscape.

The kerning problem gets less if I increase the font-size btw.

Is there a switch for activating the kerning in LibreOffice or is this a known problem?

share|improve this question
    
The bad kerning only happens on screen. When you print the document or export it as PDF, kerning is nice. –  Fitoschido Sep 13 '13 at 8:48

2 Answers 2

up vote 6 down vote accepted

Kerning is activated by using the Format->Character menu, selecting the Position tab and using the Pair kerning checkbox in the Spacing section.

enter image description here

share|improve this answer
1  
The kerning seems still to be way off. (Maybe it's the font-hinting that screws it up.) Still, this activates kerning, so I'm marking it as correct. I wonder why this isn't activated by default. –  Georg Schölly Jan 21 '12 at 15:49
1  
That might be related to some regressions introduced with the switch to graphite2: bugs.freedesktop.org/show_bug.cgi?id=36703 –  Bjoern Michaelsen Feb 19 '12 at 13:10
2  
I turned off kerning (was on by default as of LO shipped with Ubuntu 12.10) and had better results. The kerning is horrendous. I mean, it's epically bad. It's worse than Microsoft Word '98 kerning, OK, that's how bad it is. Letters just get sucked into their neighbours, or pushed away seemingly arbitrarily. It is not flattering to the LO suite of tools. To be fair, this is only from screen display; print appears to have nice kerning. –  Dakota Jan 16 '13 at 6:31

Do a "Select All" before you turn kerning on. Otherwise it will apply only to a local selection, possible the current paragraph.

(I am using up to date libreoffice on a Mac, but this should still apply.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.