Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an external USB HDD IDE enclosure that I use to back up and then wipe old hard drives.

My questions is:

How do I prevent Ubuntu Server from auto mounting these drives?

Most of the instructions I've seen online refer to turning off auto mounting for Desktop installs.

EDIT:

To clarify, I am plugging in the usb enclosure AFTER the machine is running. I don't want it to auto mount when I plug in and turn on the power to the external enclosure.

share|improve this question
1  
Is this happening because you also have a desktop like Gnome installed? –  nealmcb Feb 7 '11 at 4:50
add comment

2 Answers 2

I've never seen Ubuntu Server automount on default install. I expect that at some point you installed the automount package. If you remove that, it should stop the behavior. msw's instructions for adding the drive to fstab with the noauto mount option are good instructions, though i would add that i recommend using UUID in fstab to id the drive if it's hotpluggable, as the /dev/sdX address may change when you plug the drive in at different times.

share|improve this answer
add comment

Probably by using the noauto option in /etc/fstab like:

UUID=01C4B957CD91E340 /mnt/usbhdd   ext3  noauto,rw,exec 0 0
/dev/sdf1             /mnt/usbhdd   ext3  noauto,rw,exec 0 0

Where sometimes the drive is specified by UUID and sometimes device name so I showed both forms.

share|improve this answer
1  
That makes sense for a drive that was already set up in fstab. I am asking about a drive being plugged in AFTER the machine was up and running. –  alexpotato Oct 26 '10 at 16:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.