Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to connect to Internet using Samsung corby Mate in Ubuntu 11.04 which shows using:

$ lsusb     
Bus 005 Device 005: ID 04e8:663f Samsung Electronics Co., Ltd SGH-E720/SGH-E840
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The mobile broadband creates a connection but doesnt connect to internet.

Mobile broadband fails to connect.

Somehow on Internet I found scripts to connect to Internet, but now only browser can access it, Ubuntu Software center does not recognize this connection and when try to install any software it doesnt display active internet connection.

I am using two chatscript & connection in /etc/ppp/peers & /etc/ppp respectively.

share|improve this question

1 Answer 1

I never got my old Samsung to connect using the Mobile Broadband option in Ubuntu, but i have had success using wvdial (downloadable from Software centre).

  1. Install wvdial from Ubuntu Software Centre
  2. run wvdialconf in shell; this will generate the file /etc/wvdial.conf
  3. You have to edit /etc/wvdial.conf; try copying the contents posted here or here. (The second link is what i used, but the first one specifically refers to your phone) You have to substitute the part "airtelgprs.com" with the name of your net connection,which you can get from "Network settings" in your phone,as well as the fields Username and Password;
  4. To connect type sudo wvdial; it might take several seconds for the phone to connect; Usually when wvdial prints the DNS server addresses, it indicates the connection has been established.

Note: This is how i connected via usb.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.