Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

YouTube videos play fine in Firefox and Chrome. However, Vimeo videos are always choppy. What can I do to get them to play normally?

I'm running a Tecra A4 with a VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]

Screenshot per comment request alt text

share|improve this question

closed as off-topic by Braiam, guntbert, karel, Eric Carvalho, Seth Nov 11 '13 at 16:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, guntbert, karel, Eric Carvalho, Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

    
How much is your CPU used (and how many cores do you have) while you're watching the video? –  erjiang Nov 2 '10 at 3:02
    
How do I find that out? –  Davious Nov 3 '10 at 11:41
    
Close voters see askubuntu.com/a/13690/169736 –  Braiam Nov 7 '13 at 0:47
add comment

5 Answers 5

Try this:

sudo mkdir /etc/adobe 
echo "OverrideGPUValidation=true" > ~/mms.cfg 
sudo mv ~/mms.cfg /etc/adobe/

It will force Flash Player to bypass its GPU validity checks.

Make sure you have the latest driver for your graphics card.

Source: http://blogs.adobe.com/penguinswf/2008/08/secrets_of_the_mmscfg_file_1.html

share|improve this answer
    
Thanks for the suggestion. I tried that code, it didn't change things for me. –  Davious Oct 30 '10 at 2:07
    
@Davious Do you have the latest driver for your video card? –  lovinglinux Oct 30 '10 at 4:04
    
Yep. It's an ATI card on a Tecra A4 –  Davious Nov 1 '10 at 23:06
    
@Davious Please add your hardware information to your original question. –  Jorge Castro Nov 1 '10 at 23:41
add comment

Get FlashVideoReplacer, an extension for Firefox that I develop, which allows you to watch YouTube, Vimeo and Blip.tv with a different plugin like gecko mediaplayer, gxine, kaffeine, mozplugger, totem or xine. CPU usage will drop considerably and you will be able to watch fullscreen HD.

share|improve this answer
    
Thanks for your suggestion. I added the plug-in and I still see choppy vimeo videos. –  Davious Oct 27 '10 at 3:03
    
Are they being loaded with a different plugin or still with flash? Please post a screenshot. –  lovinglinux Oct 27 '10 at 10:05
    
@Davious I can't see which plugin you are using from the screenshot. –  lovinglinux Nov 1 '10 at 23:45
    
Hmm.. let's see. I just realized that I needed to go to Ubuntu Software Center and install Gnome MPlayer with the gecko mediaplayer option. I installed that. Still choppy video. But I sense I'm making progress. –  Davious Nov 2 '10 at 0:39
    
I'm not sure what to add to the screenshot to make it more helpful. I invite suggestions. –  Davious Nov 2 '10 at 0:39
show 3 more comments
up vote 0 down vote accepted

I've lost possession of the laptop, so I'm going to "close" this question with an answer that doesn't answer the question.

share|improve this answer
1  
Thank you for doing this, it helps keep the site clean and tidy. –  Seth Jan 6 '13 at 1:33
add comment

Vimeo offers a HTML5 version of their player as alternative to Flash. It works much smoother for me.

share|improve this answer
1  
This is really a comment, not an answer to the question. You can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  hexafraction Aug 17 '12 at 16:25
1  
Rather than being a half-answer in a comment, this answer should instead ideally be modified to explain how to use the HTML5 version of the player, or at least to contain a link to information about it. –  Eliah Kagan Aug 26 '12 at 19:51
add comment

I just thought I would add my 25cents because I came here looking for help for a similar issue a few minutes ago. Until 30seconds ago, all Vimeo gave me was a still image of the video but no play button. YouTube was fine, and I could watch Vimeo vids via Chrome. The short answer is, I decided to disable Flashblock and that did it. So while that may not be your answer, it might be helpful to the next guy (like me) who bumps into this thread.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.