Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A little bit of a disclaimer, I have very little knowledge of the correct terminology for some of the things I'm going to ask about, and I apologize in advance

I have a Nexus S 4g phone that is, at the moment of writing, connected to my 11.10 computer through its USB charger cable. In the past, connecting the phone like this has allowed me to transfer files between my computer and my phone; I'm able to get my music onto my phone, and my photos onto my computer, for example. For some reason, this has stopped working. My phone still charges its battery when connected to the computer, but neither the computer nor the phone recognized that they are connected.

Is there something I can do to get the phone and the computer to detect each other? I don't know how to fix this, and it's more than a little frustrating. Any help would be greatly appreciated.

share|improve this question
Had you just updated your phone SO?. Android has stopped connecting as a mass storage device in their last version (to allow the phones to use ext partitions and let windows recognize them). – Javier Rivera Jan 17 '12 at 8:29
This sounds like a hardware fault more than anything. – coversnail Apr 30 '12 at 9:42

Newer Android devices (as of 3.0 Honeycomb) no longer support USB Mass Storage for the internal storage, because that allows Android to not have to support the FAT32 file system. In order to connect to a 3.0 or later device over USB you'll need to use something that speaks MTP; there are a few applications for Linux which do so such as aafm or gmtp. I have had the most success using mtpfs, although it's not really that user-friendly to work with.

You can also try one of the many ftp/scp/bluetooth file transfer tools for Android and see if that does what you need. Astro has a few file transfer plugins available, and there's also several FTP clients and servers as well. I find that to usually be less of a hassle than MTP, although it also tends to be slower since it has to go over the network (or Bluetooth) instead of USB.

share|improve this answer

If you are really using the Nexus S 4g try this:

On my Samsung Galaxy S+ I had to go to system settings -> Applications -> Developement -> and then check USB Debugging in order to have the phone work like a usb storage device. Since the Nexus uses another android version I believe, there might have been some changes...but just try

If you are using the Galaxy Nexus (the new one that just came out...with android 4.0 on it)
This instruction should help you:

share|improve this answer
I have tried the how to from that link. The problem with this is that neither the computer nor the phone recognize that they have been connected. All that happens is that my phone's battery charges – Newbie in over his head Jan 26 '12 at 6:10

I recently made a post here on how to connect the Nexus 7 to an Ubuntu laptop. This should be applicable to your phone as well, just make sure you replace the Nexus 7's device id (18d1) with your phone's device id (you can find the device id by running mtp-detect | grep idvendor after installing the mtp-tools packages).

share|improve this answer

I had similar issues with my Galaxy S2 and Ubuntu. Here is what I did:

On your android phone, go to Application->Settings
In there, go to Wirelessand Network and select USB Utilities
Click on Connect Storage to PC
A message should pop up: Connect USB cable to use mass storage
Now connect the USB cable to computer
A green android robot should be on display with an option of “Connect USB storage“, click on it
The green robot turns orange now and now you can access the files on the SD card of your phone


I wrote the above mentioned post afterwards and it has solved the problem of many people since then.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.