Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Stats of what I'm running:
TV: HP MediaSmart TV 47" / OS: Ubuntu 10.10 64-bit / Video Card: Nvidia GeForce GT 220 / Video Driver: Nvidia 260.19.06

When I first setup Ubuntu on this computer, after rebooting, the display resolution did not save. I eventually fixed this by manually changing the display to the correct resolution in the xorg.conf file. But I'm still unable to make the overscan setting persist after a reboot. I've tried adding nvidia-settings -l to my autostart, but this does nothing. I've also run the Nvidia Settings app with sudo and saved the changes, but this hasn't fixed the issue either. I also noticed that there is a .nvidia-settings-rc file in my home directory that stores settings and there is a field HTPC64:0.0/OverscanCompensation[DFP-1]=115 which IS correct, but this file and/or settings related to it don't seem to be saving because I still have to manually adjust the overscan in the Nvidia Settings after a reboot. What else can I do to resolve this?

share|improve this question
    
I'm really surprised nobody has replied to this yet because I've seen some amazingly intelligent people providing solutions on this site. And I really don't think the problem I'm having is that difficult to figure out (at least for one of the pros). For now, I have temporarily fixed this myself by adding a startup shortcut that runs the command: "nvidia-settings --assign 0/OverscanCompensation[DFP-1]=115". However, this overscan issue is a problem before I ever login. I'd REALLY like to find a way to fix it before I'm even logged in. Can someone please help? –  John 'Shuey' Schuepbach Jan 19 '12 at 5:30

1 Answer 1

up vote 2 down vote accepted

I hope this isn't too late. I ran across your question as I was having the same issue. Open the nvidia-settings program. Set the overscan and various other goodies to your liking, then on the "nvidia-settings configuration" option in the left hand combo box, click on "Save Current Configuration" leave the default as ~/.nvidia-settings-rc.

Then open your ~/.xinitrc file, and add nvidia-settings -l to any line before the exec ... line or if/case structure containing it that points to your display manager of choice.

If you're unsure, somewhere near the top should suffice.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.