Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed the driver from Additional drivers I can run nVidia configuration utility which recognises the GPU but when I go to system info it says

Driver : Unknown Experience : Standard

Also when I move windows around the desktop they move slowly or they will only move to final position when I stop moving the mouse also CPU usage rises significantly when moving a window (by 50% on 1st core and 40% on second)

share|improve this question
You should provide more information about your problem. What is your nVidia card model? It has Optimus technology? (If you dont know, post the output of the following command: lspci | grep VGA) – Salem Jan 17 '12 at 0:18
give it time .... mine laptop has a Intel HD 2000 and even after installing it took upto 3 days go show Iron Clarke thingy – sarveshlad Jan 17 '12 at 2:58

Ubuntu is recognizing your Nvidia video card driver otherwise it would not be able to activate it and you would not be able to have a 3D desktop.

It is System Info that is not recognizing the video card. It is my guess that this is because the Nvidia driver is proprietary code and not open source code.

I get the same information from System Info on my machine with Nvidia Geforce GT220. Accept this as the present situation regarding proprietary video drivers.

Last night I ran a test on a default install of 12.04 Beta 1. I deactivated the Nvidia driver and I re-booted. I got a 2D desktop running under the open source video driver called Nouveau.

In 12.04 System Info is called Details. The details of my graphic set up under Nouveau are:

Graphics: VESA:GT216 Board-0682vb12

Driver: 0682vb12 Experience:


Notice, that the graphic experience is listed as standard. This means 2D. In 12.04 you can confirm this by running System Settings>Appearence. If you see a method of adjusting the Launcher icon size, then you are in 3D. You do not get (at present) a method to adjust the Launcher icon size in 2D.

When I re-activate the Nvidia driver, Details (System Info) says:

Graphics: Unknown

Driver: Unknown

Experience: standard

The experience is standard even though I know I am in 3D mode. I can see the effects. Therefore I conclude that System Info at present cannot get information from a proprietary video driver because it is closed source code.

For your information, the video card that you have is a key component for having a good visual experience in any operating system.

You do not give us your hardware specifications. Does your video card have a powerful GPU (Graphic Processing Unit)? How much video memory is on the card itself? This can make all the difference to a user's visual experience.

share|improve this answer
Great answer mate. – Mark Kirby Jul 20 '12 at 15:17

Had a similar problem, found by adding this repo and updating my NVidia drivers worked for me:

share|improve this answer
Plus try: Compiz-Setting-Manager.... Composite: AUTO DETECT REFRESH (UNTICK): REFRESH RATE SLIDER (MAX)..... MOUSE POLLING: (1) – pst007x Mar 17 '12 at 11:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.