Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a long-term problem with my Acer TravelMate 3002WTMi (Pentium-M 1.73Ghz, 512 MB RAM) and Xubuntu 11.10. Whenever load increases machine tends to slow down to the point that it's totally unresponsive (for 10-30 sec. intervals which is very annoying). It always happens when i.e. Gmail and Youtube tabs are open with a browser.. I've been running Linux on desktop machines with less memory but I don't recall having such problems, besides I chose to run Xubuntu so it's really hard to blame memory. Nevertheless OS reports this memory usage while ONLY running xterm and default desktop (after dropping VM caches):

pkug@travelmate:~$ free -m
             total       used       free     shared    buffers     cached
Mem:           423        155        267          0          7         70
-/+ buffers/cache:         77        345
Swap:          500         67        433

Meanwhile process monitor tells that Xfce itself eats just around ~17 MB. Sometimes I don't get why so much memory is used when just doing nothing. Back to the original issue, is there anything I can do to prevent such slow downs ? I tried using different block scheduler, stuff like zramswap, tuning filesystem with data=writeback, experimenting with vm.swappiness (currently it's set to 10).. not much of a help. Here are the disk performance results:

pkug@travelmate:~$ sudo hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   1624 MB in  2.00 seconds = 812.32 MB/sec
 Timing buffered disk reads: 102 MB in  3.05 seconds =  33.48 MB/sec
share|improve this question

3 Answers 3

This sounds awfully like kernel bug 12309, which I've been suffering from for a long time and with several linux distros. I've tried several solutions, the only remaining is zramswap and putting in an SSD with a big load of RAM. I tried with different IO schedulers and setting noatime in fstab and that didnt help. Funny thing is that a friend of mine has a older laptop than me, and he dosen't suffer at all from this problem.

share|improve this answer
    
Thanks! this seems to be fixed in 3.2 and I can feel great performance improvements. Try upgrading. Memory consumption is still awful though.. :) –  user40613 Jan 20 '12 at 8:59

OP has resolved issue by upgrading;

Thanks! this seems to be fixed in 3.2 and I can feel great performance improvements. Try upgrading. Memory consumption is still awful though..

share|improve this answer

When you use zramswap, make sure you disable the swap on disk, or at least set it to a low priority ( add the pri=0 option in /etc/fstab ). Any time things actually have to be swapped out to disk it is going to be SLOW.

share|improve this answer
    
Thanks, I've tried that. Actually if you use zramswap-enabler script it sets the swap priorities automatically. Anyway to be honest I don't see any improvements when using zswap, sometimes it even feels slower. I am considering recompiling optimized kernel as my last chance now. –  user40613 Jan 17 '12 at 13:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.