Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Ubuntu 11.10 on a new PC I have sound working and I have the Login Sound working but I don't get any other alert / notification sounds. e.g. If a question box pops up - there's no sound.

I've tried some other suggestions like copying all the sound files to the /usr/share/sounds folder but this hasn't helped.

Any ideas will be greatly received.

share|improve this question
    
Did you take a look at this question - re-enable "popping" sounds –  nitstorm Jan 16 '12 at 18:39
    
Yes I've done all of those things and they don't make any difference to my alert sounds not working. Thanks for the advice. –  Peter Jan 17 '12 at 9:59

3 Answers 3

up vote 1 down vote accepted

This issue has been resolved in Ubuntu 12.04 by enabling system sounds using Ubuntu Tweak - Ubuntu Tweak

This worked for me in Ubuntu 12.04.

share|improve this answer

I hope my answer isn't too simple, but did you check the volume control for alerts?

This has gotten me before... in the system settings, under "Sound", there is, in addition to the "Output volume" at the top, a slider for "Alert volume" in the Sound Effects tab.

I've been bit twice when this was set to minimum, and a lot of sounds didn't seem to work.

share|improve this answer
    
Hi, I've checked this and yes the volume is NOT at zero. And when I click on the Alert volume slider I hear a POP sound. So I know it should be working. –  Peter Jan 17 '12 at 9:57
    
Sorry, but I thought it was worth mentioning. So, it's only alerts, not regular audio and video? If so, the only other thing I can think of is that the sound files are either bad or not playable. Can you play them with an audio player? Or, if not, can you specify a known-good sound for the alert? –  Marty Fried Jan 18 '12 at 2:37
    
Hi,I've been able to play all of the sound files which are in the /usr/share/sounds folder and all sub-folders too. So that should mean that the files are fine. –  Peter Jan 18 '12 at 11:39
    
Just another point of interest, The files in the sounds/freedesktop folder have the extension .oga where as the files in the /sounds/ubuntu/ folder are .ogg. Do you know if this has any impact? Also, which sound file is the system set to use as a default? –  Peter Jan 18 '12 at 11:45
    
I haven't paid a lot of attention to the details, probably because there doesn't appear to be much ability to configure them. So, I looked closer so I could at least tell you what my system is like. The alerts that can be selected in the sounds setting are in gnome/default/alerts - there are 4 (bark, drip, etc). Do these work in the sounds dialog when you click on them? They should make a sound simply by highlighting. I'm not sure if my dialogs make a sound - they might not. I do know Skype makes lots of sounds, and these are the ones I found to be very low volume initially. –  Marty Fried Jan 18 '12 at 16:44

I have found the answer to this problem, at least for my system. It is not a sound problem, it is a Compiz problem.

I went into the system settings => universal access => hearing tab, and turned on the visual alerts. Nothing happened when I pressed the test button. So, I thought that the event was not being fired. I also tried typing echo -e "\a" in gnome terminal, and no sound was emitted.

I then ran metacity --replace and the sounds started working in all places, as expected. Returning to Compiz (compiz --replace) made them stop.

EDIT: I guess I was in the gnome compatibility mode when I did this test, and did not realize it's harder in Unity, because the window manager doesn't appear to run and Alt-F2 doesn't work. However, I tried it in Unity, and was able to bring up the Terminal using Alt-Ctrl-T, then ran "Compiz --replace&" from that to get back to Unity.

Sorry to anyone who may have suffered due to my post.

share|improve this answer
    
So it's nothing that I've done wrong - and basically nothing I can do to resolve the problem! I just have to wait for someone to fix ubuntu 11.10 or hopefully 12.04? –  Peter Jan 19 '12 at 22:09
    
I guess so, unless you want to switch to metacity. It can be done without logging out, by the way. I filed a bug report in the Compiz bugzilla (bug report #70). –  Marty Fried Jan 19 '12 at 22:29
1  
I tried switching to metacity and I lost all function of my desktop - no unity bar - no menus I had to turn off my computer just to get back to a usable system. Very strange. But thank you very much for your help. I can stop thinking about it now and just wait for a fix in the future. –  Peter Jan 20 '12 at 23:06
    
Oops! Sorry to have caused you problems, but I'm glad it came back. I've had that happen at various other times, often when clicking on one setting in CCSM or something similar. So, you weren't able to run any commands at all, like with Alt-F2? –  Marty Fried Jan 21 '12 at 0:28
    
Marty - thanks so much for your help. –  Peter Jan 21 '12 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.