Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I installed LUbuntu 11.04 on my VirtualBox. I couldn't find the 1366x768 resolution so I installed Guest Additions but it wasn't there. So I used this code to set the correct resolution:

gtf 1366 768 60
xrandr --newmode "1368x768_60.00"  85.86  1368 1440 1584 1800  768 769 772 795 $
xrandr --addmode VBOX0 1368x768_60.00
xrandr --output VBOX0 --mode 1368x768_60.00

The problem is that I can't find a way to save this information for the next reboot. I tried on .xinitrc and nothing happens. Then I tried on .bashrc but it's not working, I need to start a console before this commands are executed.

share|improve this question
    
You could try putting those commands into your /etc/rc.local. –  onse Jan 16 '12 at 20:00
    
I edited the file and I changed the execution bits but it's not happening. Maybe LUbuntu works differently. –  dierre Jan 17 '12 at 9:18

4 Answers 4

up vote 4 down vote accepted

I was trying to change the default resolution of LXDE on Ubuntu (LXDE is also used in Lubuntu) and I found a solution for this problem. I also have Lubuntu installed and I've checked that this file actually exists which it does (Ijust tried this fix as well and it worked).

So, the fix....

  1. Open up a terminal, press ctrl+alt+t
  2. I'm guessing you have a default Lubuntu install, so "Leafpad" would be your default editor, type/copy this into the terminal and press enter... (you may be asked for a password)

    sudo leafpad /etc/xdg/lxsession/LXDE/autostart
    
  3. Now add your commands to the bottom of the file adding a @ before the actual command. Mine looked like this after...

    @xscreensaver -no-splash
    @lxpanel --profile LXDE
    @pcmanfm --desktop --profile LXDE
    @/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
    @xrandr --auto --output DVI-1 --primary --mode 1680x1050 --left-of DVI-0
    
share|improve this answer
1  
Worked like a charm. –  dierre Mar 3 '12 at 9:43
    
@captain_G I have no LXDE directory only a Lubuntu and Lubuntu-Netbook directory. What should I do? –  Pineapple Under the Sea Aug 4 '12 at 3:43
    
@Severus - Open your terminal as above. type "cd /etc/xdg/lxsession/". That should take you to lxsession directory. Now type "find -name autostart". Hopefully that should show you the directory with autostart in. If I remember correctly I 2 directories you have are for the different sessions available. You could add it to both of them or just the one you are using. Hope this helps (sorry for the late reply!) –  captain_G Aug 26 '12 at 21:02

I personally put those sorts of commands, to be run at login, in a script in ~/bin , call it set_resolution

Then run gnome-session-properties and add the command to be run at login (use ~/bin/set_resolution).

enter image description here

share|improve this answer
2  
It's LUbuntu, non Ubuntu, so I do not have gnome-session-properties –  dierre Jan 17 '12 at 9:05
1  
Openbox (Lubuntu) uses ~/.config/openbox/autostart –  bodhi.zazen Jan 17 '12 at 15:53
    
still not working. I've added ~/.config/openbox/autostart then chmod u+x but at reboot nothing is happening. –  dierre Jan 17 '12 at 16:46

Here's another line added to my /etc/xdg/lxsession/LXDE/autostart file to get it working:

@xrandr --output LVDS --off

tip from: http://lists.freedesktop.org/archives/xorg/2007-August/027490.html

Update: the above was fine for awhile until I ran the GUI config tool lxrandr, which seems stupidly unaware of dual-monitor setups. So I made this change:

$ cat $HOME/.config/autostart/lxrandr-autostart.desktop

[Desktop Entry]
Type=Application
Name=LXRandR autostart
Comment=Start xrandr with settings done in LXRandR --then manually tweaked
Exec=xrandr --output DVI-0 --mode 1920x1200 --rate 60.0 --output LVDS --off --output VGA-0 --primary --mode 1920x1200 --left-of DVI-0
OnlyShowIn=LXDE

Note that I'm running Ubuntu 12.04 with LXDE. One would hope that a pure Lubuntu 12.04 setup would include a smarter lxrandr binary...

share|improve this answer

This page helped me : https://wiki.ubuntu.com/X/Config/Resolution

I ended up putting my changes in ~/.xprofile

share|improve this answer
    
Had the same problem as dierre, I couldn't get the xrandr settings to stick in Lubuntu 13.10, and people suggested autostart etc. However, adding the commands to .xprofile finally worked for me. Thanks! –  Beamie Jan 19 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.