Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I haven't seen this anywhere else, and this is the only major showstopping issue that I have with a transition to XFCE.

System: HP Pavillion DM1-3200US


I'm interested in moving over to XFCE, but my main issue is that media keys don't work properly. I've tried the solution provided on XFCE's Wiki (mapping the keys), but that isn't a proper solution for me - the laptop I'm on doesn't light up when the sound is muted with that solution.

I've seen that gnome-settings-daemon actually properly detects the media keys on my netbook, but when I experimented with that in a live environment, it only worked for a single session, and failed to work.

My question then becomes:

  1. Is it a good idea to use gnome-settings-daemon on my XFCE build? If so, what would I need to install/include/build/divine/hack to ensure that it worked consistently throughout a normal days' use?

  2. If gnome-settings-daemon is not a tenable long-term solution, what would I need to perform to not only get media keys to work properly, but also to get my netbook's "Mute" light to work properly?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Okay, I've taken a stab at this with the Live CD environment, and I'm confident that it will translate properly over on the full installation.


I went ahead and installed gnome-settings-daemon and added it to the start-up list of programs. After disabling the XFCE Volume Daemon (or xfce4-volumed) from the start-up list, and updated xfce4-power-manager, I'm able to report that my media keys are working as expected in my Xubuntu session.

Now, I have to figure out how to get them to work when on the login page. But I won't despise a small beginning here.

share|improve this answer
    
Updates to your question go in your question, not in here. –  Uri Herrera Jan 17 '12 at 2:12
2  
Wasn't an update to my question; I believe that this is an answer to the question. I have to wait 48 hours to accept it, though. –  Makoto Jan 17 '12 at 3:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.