Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to install python-nautilus using the Ubuntu Software Center I get an error message titled "Package dependencies cannot be resolved".

The following output is displayed in the details section:

Package dependencies cannot be resolved

The following packages have unmet dependencies:

python-nautilus: Depends: libc6 (>= 2.2.5) but 2.13-20ubuntu5 is to be installed
             Depends: libglib2.0-0 (>= 2.16.0) but 2.30.2-4ubuntu1~oneiric1 is to be installed
             Depends: libgtk-3-0 (>= 3.0.0) but 3.2.0-0ubuntu3 is to be installed
             Depends: libnautilus-extension1 (>= 1:2.91) but 1:3.2.1-0ubuntu3.2 is to be installed
             Depends: libpython2.7 (>= 2.7) but 2.7.2-5ubuntu1 is to be installed

This output doesn't make sense for me. Depends on libpyhon2.7, and version 2.7.2 is available... What is going wrong here?

Next, I tried to install python-nautilus from command line:

username ~$ sudo apt-get install python-nautilus
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-nautilus : Depends: python-gobject but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

However, python-gobject is already installed:

username ~$ sudo apt-get install python-gobject
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-gobject is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

To me it looks like my package index must be hopelessly broken. However, I did not have any problems with other packages, yet. I am using a nearly fresh Version 11.10 of Ubuntu. I tried executing `apt-get update && apt-get upgrade`` but this doesn't change anything.

Any hints how I can fix this issue are appreciated.

share|improve this question
up vote 3 down vote accepted

Your error messages are probably related to the fact that you have Gnome-3 PPA enabled.

A recent change in this PPA promoted the use of python-gobject and deprecated the use of python-nautilus.

Basically you can't have python-nautilus installed.

You have a couple of choices:

  1. Stick with using the PPA and you cannot continue using nautilus-actions etc.
  2. ppa-purge the Gnome-3 PPA and you will then be able to use nautilus-actions etc.

You should perhaps post a bug-report on the Gnome-3 PPA to see if they have any thoughts on backporting nautilus-actions from Precise to Oneiric.

share|improve this answer
The version of nautilus-actions available in oneiric is non-functional, wasn't rebuilt for gtk3 till precise. *the 3.1.4 or 3.1.5 source can be self built on oneiric – doug Jan 16 '12 at 15:16
Wow, I impressed that you found out that I have Gnome3 PPA enabled! After ppa-purge I could install python-nautilus without problems. Thank you! – Flo Jan 17 '12 at 12:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.