Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First I uninstalled mplayer and replaced it with mplayer2 since it is supposedly capable of gapless playback.

Now I know gtstreamer can do gapless but some of my files have glitches when using the gtstreamer option in the audio preferences of Gmusicbrowser which is why I am using the mplayer option instead. Now what exactly do I put in the options box to make playback gapless on gmusicbrowser using mplayer2?

share|improve this question
add comment

2 Answers

Gapless audio in gmusicbrowser using mplayer2 works just fine on my end. Here are the steps I followed to get it working:

First, you will need to get the latest build of mplayer2. MOTU media maintains such packages for Oneiric and Precise. Run these commands to add them to your sources:

sudo add-apt-repository ppa:motumedia/mplayer-daily
sudo apt-get update
sudo apt-get install mplayer2

Next, start gmusicbrowser and open "Settings". Go to the "Audio"-tab, and choose mplayer. To enable gapless playback, press the "advanced options" button and enter "-gapless-audio".

That should do it!

share|improve this answer
add comment

Enabling the gapless option (-gapless-audio) in SMplayer2 doesn't work. So probably it (the same command) won't work in Gmusicbrowser as well.

I've tried all of the Linux music players, but only those consistently support gapless playback:

  • DeadBeef
  • Auqualung
  • Audacious
  • MPD
  • XMMS2

Adding the Gstreamer developer PPA solves the gapless issue in Guayadeque and may do so in Gmusicbrowser as well. Guayadeque got better by the way, and it's better than GMB.

You can find the Gstreamer developer PPA here.

Enter in a terminal:

sudo add-apt-repository ppa:gstreamer-developers/ppa
sudo apt-get update

Then launch Synaptic and on the left click Status, then click Installed (upgradable) and upgrade all the gstreamer related packages. I've left one of them asking to remove many other packages. Installed others and closed Synaptic.

Then Update manager itself asked to upgrade the one I've left un-upgraded before. Updated this as well accepting the remove gnome-media warning.

No problem so far. Guayadeque plays gaplessly now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.