Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I installed the GNOME shell in Ubuntu, I decided that I didn't like having the "Close/Minimize/Maximize" buttons on the right, so I switched them over to the left using

gconftool-2 --set "/apps/metacity/general/button_layout" --type string "close, minimize, maximize:"

After resetting the shell, however, I found that with the GTK+ theme, only the close button shows up. Using system title bar and borders will make all the buttons appear, but I really want to use the theme because the system title bar makes the top bar too thick.

Logging out and back in didn't fix it, and I tried reinstalling Chrome, but the problem persists.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Okay, I've found a workaround involving the use of Ubuntu-Tweak. Using Window Manager Settings, check Custom under Window Titlebar Button Layout. Then simply moving one of the elements to a different location and then moving it back again will cause all the buttons to appear correctly.

share|improve this answer

One way to fix this is to install gnome-tweak-tool. Once installed and launched select "Shell" and you will have some options for the titlebar buttons.

I think this is what you are after.

gconftool-2 --set "/desktop/gnome/shell/windows/button_layout" --type string "close, minimize, maximize:"

After that just restart gnome-shell.

share|improve this answer
    
hmm... nope. And after resetting the shell, the buttons are back on the right again. –  TreefrogInc Jan 16 '12 at 0:19
    
Updated answer with what I think is the correct key to set using gconftool-2. –  Zoke Jan 16 '12 at 0:32
    
heh. now everything only has the close button... –  TreefrogInc Jan 16 '12 at 0:49
    
Well, I've found a workaround, but it won't let me answer my own question because I have less than 100 reputation (I have 99. So close...) So I'll need to wait 6 more hours to answer, unless someone would be kind enough to bestow me with one more reputation point. –  TreefrogInc Jan 16 '12 at 1:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.