Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 8 workspaces in use throughout the day arranged as 2 rows x 4 columns.

Workspaces are numbered logically from 1-4 for the top row left-right, then 5-8 for the next row.

I would like to be able to switch to a workspace using the keyboard combination Ctrl-num where [num] corresponds to number [1-8] on my numeric keypad.

Gnome/Compiz already allows me to switch workspaces via Ctrl-Alt-up/down/left/right or at least that is how I have configured it.

Finding a way to make the mapping and behavior described above however is still confounding me.

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Under Preferences -> Keyboard Shortcuts you can map up to 12 workspaces. You can find needed entries under Window Management -> Switch to workspace #.

share|improve this answer
    
So simple, thanks! I was looking in the wrong place i.e. Compiz settings. Thank you. –  codeitagile Oct 26 '10 at 11:50
    
You should mark as correct the answer. :) –  skalka Oct 26 '10 at 11:57
    
When I try this with, say, Ctrl-Alt-Num7, it reports Ctrl-Alt-7 as the hotkey, but instead of taking me to the corresponding workspace, it does something else (eg widens the window with focus). Moreover, hitting Ctrl-Alt-7 does nothing. It works perfectly fine if I set the hotkey as Ctrl-Alt-7 (ie not using the keypad 7 key). –  Noel Yap Jun 4 at 3:52
    
The problem was that Unity Tweak Tool had Window Snapping turned on. Once I turned it off, the redefinitions for some of the Num keys (Shift-Crtl-Alt-Num? still didn't work) started working. –  Noel Yap Jun 4 at 16:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.