Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Marlin file browser, from the marlin-dev ppa.

Problem is, wehn i try to launch it, i get this error:

stewart@StudioLaptop2:~$ marlin
marlin: error while loading shared libraries: libunity.so.6: cannot open shared object file: No such file or directory

What should I do?

P.S. - I've tried it in Gnome-shell and Unity, but get same error :(

share|improve this question
    
Remove Unity 5.0 and install back the original Ubuntu 11.10 Unity and it will work. Without it, many applications compiled against Unity will fail to start. –  Alin Andrei Jan 15 '12 at 22:37
add comment

3 Answers 3

Not a very proper solution ...

  sudo ln -s /usr/lib/libunity.so.9 /usr/lib/libunity.so.6

... but it works as expected.

share|improve this answer
add comment

Solution (at least for ubuntu 11.10 oneiric ocelot):

sudo apt-get install libunity6

To find the package of an installed file:

$ dpkg -S libunity6
libunity6: /usr/lib/libunity.so.6

To find the package of a missing file:

  1. Go to http://packages.ubuntu.com
  2. Scroll down to "Search the contents of packages" and type in the filename, e.g. libunity.so.6

..and voila!

share|improve this answer
add comment

Install apt-find and search the required packages:

apt-find libunity.so.6

It should give You the name of the package containing the required lib. Then write:

sudo apt-get install package_name

It will help only if the problem occurs because of unresolved dependencies. If it doesn't help, try reinstalling the software.

share|improve this answer
    
what You mean? Where is written that there's no apt-find? –  Misery Jan 24 '12 at 8:01
    
My apologies, it appears the answer I linked to has been deleted. Regardless, I'm just pointing out that I too cannot locate apt-find in the official repositories. What version of Ubuntu are you using? –  WarriorIng64 Jan 24 '12 at 8:18
    
Also, searching for apt-find at packages.ubuntu.com turns up nothing, regardless of version. I'm guessing you are using an older release (i.e., pre-Lucid). –  WarriorIng64 Jan 24 '12 at 8:25
    
Im using Lucid, but haven't been using apt-find for a while so i just didn't know it has been removed. What is instead of it? –  Misery Jan 24 '12 at 14:50
    
It looks like the command to use is now apt-file (specifically, the apt-find libunity.so.6 command would be replaced by apt-file search libunity.so.6). –  WarriorIng64 Jan 24 '12 at 15:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.