Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I shut down my computer it always gets stucks on the shut down screen (where it displays the Ubuntu logo and the little dots). I tried to shut it down through shell, I checked the init. process, shell and everything. I can't find out where the problem is! I tried to shut down through terminal session and still the same problem.

I have to shut down with power button every single time. Anyone got a solution?

share|improve this question
    
When the purple screen appears press down arrow key so that purple screen goes and console text appears, it shows the ongoing processes, can you do it and tell at what exact line does the shutdown gets struck? –  kernel_panic Mar 29 '12 at 15:41
    
Are you using fglrx? This has some incompatibilities with certain window managers that lead to a kernel panic at shutdown. If this is the case, you can try to use the open source drivers instead. –  soulsource Apr 3 '12 at 13:51
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  coversnail May 10 '12 at 8:41
add comment

closed as off topic by jrg May 10 '12 at 12:56

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

I reliably have this problem with Xubuntu 11.10 on my Mac Pro. (And I have waited 10 minutes by the clock and it's still hung!) I have found that if I wait for about one complete cycle of the dots (sliding bar on Xubuntu), then hit the Escape key, it usually completes the shutdown at that point. If instead I get the console, I wait for it to say it's shutting down all processes and finally posts a message saying it will halt. Hitting Escape again after that message completes the shutdown (otherwise it hangs here "forever"). It's manual, but seems to work.

share|improve this answer
add comment

I had this problem with my Kubuntu 11.10 installation at one point. It turned out that it only occurred when I had my WiFi turned on (it was on a laptop). In the end, a KDE update solved the problem.

If you're using a laptop, you might want to try turning the WiFi off before shutting down, to see if that is the cause. If so, make sure you've installed any available updates, and maybe check your WiFi drivers. I also found that closing the GUI with Ctrl+Alt+Backspace when stuck and using the

sudo shutdown now

command made the computer shut down properly.

share|improve this answer
add comment

protected by Community Apr 4 '12 at 10:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.