Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting the following error whenever I try to install anything using apt-get install:

liam@Liam-Tosh-Linux:~$ sudo apt-get install chromium-browser
[sudo] password for liam: 
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

What is causing this error?

share|improve this question
    
Do post if the idea worked –  kernel_panic Jan 15 '12 at 14:20
    
possible duplicate of Fixing Could not get lock /var/lib/dpkg/lock –  Lekensteyn Feb 11 '12 at 18:12

1 Answer 1

up vote 2 down vote accepted

If some other installation (eg via Software center) is going on on your computer you will not be able to install anything from from your terminal, So, Check if some installation is going on USC, if yes cancel it, if not restart your computer and "apt-get install" again, you will be able to install,

share|improve this answer
    
A restart worked –  Liam W Jan 18 '12 at 18:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.